Toyota Nation Forum banner

1 - 9 of 9 Posts

·
Registered
1997 Camry LE 4cyl 163,000 miles 2009 Camry LE 4cyl 112,000 miles
Joined
·
9 Posts
Discussion Starter #1
Hello all, So initially I was getting a P0300 and P0301 CEL. Changed spark plugs, wires and finally the 1-4 coil. P0301 went away but I'm still getting a P0300. I'm also (once every 2 weeks or so) losing power (stays at idle) where I step on the throttle and nothing happens until I floor it and the trans kicks down, RPM go to 3000-4000 and then it returns to normal. Haven't tried anything else. Thanks for any and all help. Car has 163K miles
 

·
Registered
Look in sig
Joined
·
8,991 Posts
May need to get a ODB II reader (those bluetooth and TORQUE app work) to look at LTFT and STFT. The P0300 is a generic code for engine misfire, usually has a P030x along with it.
 

·
Registered
1997 Camry LE 4cyl 163,000 miles 2009 Camry LE 4cyl 112,000 miles
Joined
·
9 Posts
Discussion Starter #4
No vacuum leaks noted. Just to clarify, I'll be driving 45 mph and I'll lose all power. It just goes to idle. I'll look into a better ODB II reader
 

·
Registered
1995 T100 2WD & 1993 MR2
Joined
·
4,268 Posts
Don't know how to check it but sounds like a faulty crankshaft position sensor.
 

·
Registered
Joined
·
1,966 Posts
this was how my intermittent injector going out was until it became permanent, then no power at all under about 4k rpm. You can check when its running bad by pulling injector wires ; the bad one won't kill it.
 

·
Registered
1997 Camry LE 4cyl 163,000 miles 2009 Camry LE 4cyl 112,000 miles
Joined
·
9 Posts
Discussion Starter #7
I also got another code P0301 with the P0300. Thanks for your help. I changed out the fuel filter and it ran good for almost a week but then did it again. At lower RPMs. Once I floor it, the trans kicks down RPM go up and clears itself out. I bought a fuel pressure tester and that is in the mail. tedmich thanks for the additional info.
 

·
Registered
1997 Camry LE 4cyl 163,000 miles 2009 Camry LE 4cyl 112,000 miles
Joined
·
9 Posts
Discussion Starter #9
UPDATE: Still have the P0300 and P0301 (always reset code after parts change). Changed so far 1. Spark plugs 2. Spark plug wires 3. Fuel filter 4. Both coils and 5. All 4 injectors. It hasn't done the stalling thing in a while. I'm running out of things to change anyone else have a suggestion? Thanks :)
 
1 - 9 of 9 Posts
Top