Toyota Nation Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I have a solara that has no heat.
I’ve replaced the blower motor resistor and
  • All the fan speeds work
  • Both the hoses coming from the firewall for the heater core are both hot
  • Changed thermostat
  • The antifreeze is topped up
I also heard where it might be the blend door actuator or the heater control valve.

does anyone know where those two things ^ are located in this specific car, or does anyone know what other issue it could be???!
 

·
Registered
Toyotas.
Joined
·
248 Posts
Post a pic of the control head. I've got the Camry service manual, not the Solara, yet they might be very similar.
If you have a knob that you turn for temperature control, check the cable that it is attached at both ends. This would seem the most likely issue right now.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Post a pic of the control head. I've got the Camry service manual, not the Solara, yet they might be very similar.
If you have a knob that you turn for temperature control, check the cable that it is attached at both ends. This would seem the most likely issue right now.
Here is the picture, I can’t find anything online for the solara controls
286911
 

·
Registered
Joined
·
94 Posts
Check your air mix servo it could have quit in the open position, you have auto air, no cable. The servo is pretty much by your right knee when seated. Pull the carpet down to reveal a plastic heater protector and remove exposing the servo. Run the car, move the temp dial and check that the servo is moving
 
1 - 5 of 5 Posts
Top