Toyota Nation Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
My 94 Camry V6 has had some idling issues for a while now. Multiple misfires, cranks for a while before start with a rough idle, gas mileage seems to be suffering, and it seems to have a lack of power. CEL came on for the CPS. Went to replace it, and noticed that the sensor on the old CPS had buildup on it. Replaced and started, a bit better, but ever so slightly. Decided to throw the old one back on to see how if there was an actual difference made. When I went to pull out the new CPS, once again, there was buildup on the sensor, the new sensor. I was wondering if anyone has maybe shot some brake cleaner or anything down there while replacing? TIA
 

·
Super Moderator
Joined
·
13,533 Posts
What kind of buildup? Grease? Does it smell like burnt rubber?... Could be the timing belt is coming apart.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
What kind of buildup? Grease? Does it smell like burnt rubber?... Could be the timing belt is coming apart.

definitely grease. Not heaps, but enough for me to wonder why the new sensor with 3 minutes of idle would have that much grease on it.
 

·
Super Moderator
Joined
·
13,533 Posts
The grease shouldn’t interfere with its functionality. It’s an inductive pickup, so it “sees” metal, namely the teeth on the ring. Most likely it’s coming from a leaking valve cover gasket, which is quite common on these engines. I wouldn’t be too concerned about it, unless it’s a really bad leak. Then it can mess up the timing belt.

As for the misfires, how old are the spark plugs and plug wires?
 
1 - 4 of 4 Posts
Top