Toyota Nation Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hello!

I have a 2000 Camry 2.2 (with tweeters and factory amp, but no JBL) and for the past 2 years have experienced a whine through my car speakers. The whine increases along with my gas pedal. As I press the gas, the whine increases. When I remove my foot from the gas pedal, the noise decreases. I believe what I'm experiencing is an alternator whine due to a bad ground. However, I'm not sure what I can do to alleviate the whine. I've tried grounding the head unit to the chassis, connecting speaker wire to the RCAs, not using a ground, but they don't work. I've also tried using noise filters for the RCAs and a noise filter through the power line. Neither worked.

I've recently discovered that when the radio antenna is not plugged in the whine is completely gone.

Has anyone experienced this problem and found a solution? For reference, I'm using a cheap Dual Electronics radio from WalMart. When I had the factory radio installed, I didn't have this issue. I'd appreicate any help, I want to solve this problem before I start school again!
 

·
Registered
Joined
·
426 Posts
I've had cheap Dual Electronics radios before. They aren't well shielded and made of thin metals. I spent almost a year fighting a whine until I just replaced the radio with another one and the whine never came back. It's worth spending the $100 on a half way decent radio.
 
  • Like
Reactions: zzyzzx

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Thanks!
I've had cheap Dual Electronics radios before. They aren't well shielded and made of thin metals. I spent almost a year fighting a whine until I just replaced the radio with another one and the whine never came back. It's worth spending the $100 on a half way decent radio.
Thanks! I've recently read that someone also had a similar issue and it turned out to be the radio, I'm gonna order another and see if that works. Will keep you posted!
 

·
Registered
Joined
·
426 Posts
Don't get another Dual! I've had 3 so far and each one was bad. The first two had the whine issue and the third was their android auto one. Thing would freeze so much. Spend the extra $20 and get the Sony or Pioneer unit they have at Walmart if you want a cheap but reliable radio.
 
  • Like
Reactions: zzyzzx
1 - 5 of 5 Posts
Top