Toyota Nation Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
So, I bought a 2000 Camry LE 4 Cylinder. I LOVE IT... But... I didn't take a close enough look when buying... There's a puff of smoke when the car starts. The engine also sounds very rough, especially when it starts cold- almost a chugging. With a stethascope, the sound seems to eminate from the water pump. I took it back to the dealer ship. They're stating it needs to now go to Toyota and the folks at the Toyota dealer ship thinks it may be a know issue. Well, if it is, it's not well known because I can't find it. Any advice on what's going on would be well appreciated. Thank you!
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Wow... you're awsome. That was a quick reply! Thanx!!!! I wonder if these are something Toyota would take care of. I'm not sure if my warranty would do it. Any idea how much the valve seals woudl cost?

again, thax!
 

·
Sweet n' Lowdown
2006 Scion tC
Joined
·
16,189 Posts
No brob, thats what we're here for! :thumbup:

Valve seals are in the realm of $700usd.

In your case you might be able to get it under warranty since your Cam is only 4yrs old.
How many miles you got on the clock?

As far as getting Toyota to recognize its a known problem... good luck.



btw WELCOME to TN!
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
oh.... Well..... thank you. Jackfruit (yeah... I named the car.... :D ) has 78000 miles on it, so I don't believe it's covered by Toyota. I have the extended warrantee through the dealership, however, so I've got my fingers crossed. Well, thanks again. I'll post what I find out from the Toyota place for the next unfortunate and impulsive fool who buys a car without getting it checked out...:disappoin
 
1 - 5 of 5 Posts
Top