Toyota Nation Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I have a 2000 solara sle..i went to work it was running fine I got off work and it only cranked but wouldnt start. My friends and I have checked fuel pump, relays and spark plugs..the ECM reads good sometimes and bad other times. Im not much of a mechanic and I don't know what could be wrong. Please help
 

·
Super Moderator
2006 Corolla XRS
Joined
·
6,934 Posts
Check your battery terminals are tight on the battery posts. Also look for any corrosion. It would be a green mess if there's corrosion.

How old is your battery?

Do you have a digital multimeter? Check voltage across the positive and negative terminal. You should see around 12.6 volts.

Also visually inspect for a cracked housing case on the battery.

Then check Google to make sure you have the correct size battery for your solara.
 

·
Registered
Joined
·
208 Posts
Easiest way to narrow it down from here is spray some starting fluid in the intake, if it starts then dies down it's a fuel issue. If not, it's a spark issue. Sounds like it will crank over but not start so checking battery is not a priority at this stage.
 

·
Registered
Look in sig
Joined
·
8,799 Posts
Easiest way to narrow it down from here is spray some starting fluid in the intake, if it starts then dies down it's a fuel issue. If not, it's a spark issue. Sounds like it will crank over but not start so checking battery is not a priority at this stage.
This too help to troubleshoot.

Is this a V6 or I4 ?
 
1 - 6 of 6 Posts
Top