Toyota Nation Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hey all so i have an issue with my new old Echo. Bought the car cheap because it wasn't starting, Replaced the battery on the car when i bought it 4 months ago with 280,000 miles and it fired right up :lol:

So about a month ago i noticed it started misfiring and throwing P0300: Random/Multiple Cylinder Misfire Detected and P0303: Cylinder 3 Misfire Detected. So far i have replaced the spark plugs and ignition coils. I pulled, tested and cleaned the fuel injectors with the spare connector, battery and carb cleaner trick. Fired it up and it ran worse than before. I went to the scrap yard and grabbed some more fuel injectors and swapped them without doing the cleaning and got the same results, cleaned them out and no change. Compression test shows good about 180-190 psi. I had to replace the alternator because it went while doing all the tests.

I then started looking around and noticed the shop that did my catalytic converter and o2 sensors didn't replace the donut/flange gasket or springs and there was a 2 inch gap between the 2 pipes. I replaced those and although very much quieter and not doing as often nor as harsh, it's still misfiring, mostly at low rpm in gear, once it switches into 2nd about halfway to 3rd its fine, so around 30-35mph. Code reader is still throwing the same codes, always cylynder 3 and random, but it really doesn't sound like its anything coming from the engine itself...at least not where the cylinders are. If it is a misfire its very subtle and just kind of...putters? :laugh:

I just want some opinions on what i should test before i take it to a shop. Also have some live data, which is all lost on me, of the test drive i did after the exhaust gasket.

Anyway thanks for any help.
 

Attachments

·
Registered
Joined
·
26 Posts
Only suggestion I have is maybe look at the valve train? Starting with the easiest stuff first of course - check that cams are in time, sprockets are in good condition, anything weird looking under the valve cover basically
 

·
Registered
Joined
·
232 Posts
I will get a p300 if my gas gets below halfway. At startup, it will sometimes run rough and trigger the CEL. If I keep the gas more than half full, I'm ok. I think I may have a fuel delivery issue and/or ignition coils, as the fuel pump was replaced but not with an ideal replacement (got it from a wrecked scion and swapped top half with bottom half...so the fuel regulator, and filter, etc. prob not in best condition). Awhile back, I had also replaced the fuel injectors. So, one of these days, when I have the $$, I was going to redo the fuel pump properly (new strainer, fuel pressure regulator, pump seal, tank seal, etc) and replace all 4 ignition coils (I saw a few venders on ebay selling legit densos for $25)..not sure if anyone can vouch for those or not) and see of that fixes the issue.

Have you noticed any pattern with your issue w/ respect to your gas tank level?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
Fixed! One of the new coils i got was faulty. Car runs like a champ now. Now lets just hope i didn't F the engine, driving for a few weeks with that misfire :rockon:
 

·
Registered
Joined
·
1,053 Posts
When my granddaughters lost a coil (P0301) I took 4 over where her car was and the first coil fixed her car. I tested the other 3 coils while I was there to avoid just what you went through. Glad you got it fixed, bought 4 coils for $40 at u wrench it just after buying her car 2 years ago. Now I have 7 good used coils, waiting for another one to crap out.
 

·
Registered
Joined
·
232 Posts
Fixed! One of the new coils i got was faulty. Car runs like a champ now. Now lets just hope i didn't F the engine, driving for a few weeks with that misfire :rockon:
I'm sure you are OK. It no weird noises or anything, call it a job well done. Well Done!.

It's always nice when stuff get's fixed.
 
1 - 6 of 6 Posts
About this Discussion
5 Replies
4 Participants
l33ch
Toyota Nation Forum
ToyotaNation Forum is a community dedicated to all Toyota models. Come discuss the Camry, Tacoma, Highlander, 4Runner, Rav4 and more!
Full Forum Listing
Top