Toyota Nation Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 · (Edited)
My 2001 Highlander has been driven in dusty Senegal for a few months now. Shortly after arriving it started having trouble with cold starts (very low idle and stalling). I eventually got it to spit out codes for Mass Air Flow Meter and Throttle Position Sensor (P0100, P0110 and P0120), both of which I recently replaced, but I'm still having the same problems. Mechanics (and diagnostics) are very hard to find in west Africa. Can anyone help with potential suggestions for the next step here? Once the car is running at normal idle, it's fine, but this sometimes takes several minutes when first starting. Although it is not necessarily only when the engine is cold. I have cleaned out the air filter recently, too. Any other ideas?

Other info:

-car is 6cyl. V6
-CEL is not on; only came on once and went off when diagnosed
-I notice there is huge range of prices for new MAF meters. Is it possible I bought a cheap- non-effective one?
-Does this car have a separate Air Intake Sensor or is this part of the MAF?


Puzzled in Africa...
 

·
Registered
Joined
·
260 Posts
This vehicle and the Lexus equivalent have trouble with the Idle Air Control Valve getting dirty, which causes a very rough idle and possible stalling. Search around on the Club Lexus forums and you will find good write-ups on how to do the cleaning. It's a little labor intensive but appears to be a magic bullet for many different circumstances.
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top