Toyota Nation Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
so i just bought a 2001 toyota prius. the speedometer shows zero whenever driving, i scanned the car and it showed the speed sensor was the reason why the check engine light was on. now i went looking around for a speed sensor replacement for the car and i could only come across an abs speed sensor on online auto stores, but i eBay i came across a transmission speed sensor. i went looking on many online auto stores an found nothing about a transmission speed sensor so im starting to have doubts whether this car even has a transmission speed sensor. but lets just say it didnt have one and i had to replace the abs speed sensor. (note: the abs light is on) there are a total of 4 abs speed sensor on the car, one on each tire, how would i know which one is bad? is there a way i can test ? thanks
 

·
Extreme DIYer
2013 Camry Hybrid LE
Joined
·
58 Posts
I would look to see if its simply unplugged first. The most likely scenario is that one of your speed sensors are unplugged or has bad wiring. Speed sensors rarely go bad.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
I would look to see if its simply unplugged first. The most likely scenario is that one of your speed sensors are unplugged or has bad wiring. Speed sensors rarely go bad.
this may be a stupid question, but is the speed sensor the abs sensor or is it a sensor on the transmission itself? thanks
 

·
Extreme DIYer
2013 Camry Hybrid LE
Joined
·
58 Posts
Yes, the speed sensor on the transmission is likely unplugged or the wiring damaged.
 
1 - 5 of 5 Posts
Top