Toyota Nation Forum banner
1 - 15 of 15 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
Hello,

I have a 2003 Camry LE my key fob stopped working a few months ago. I just replaced the DCR module and I am able to get into programming mode. I am able to add the fob (while holding lock/unlock release then press lock door will cycle) but after that the fob wont do anything. I am guessing that the fob are communicating with the with the DCR module hence the door cycle. Any help would be appreciated.
 

·
Registered
Joined
·
33 Posts
I have the same problem with a 2006.

Did your old module and the replacement respond the same?
Where did you get your replacement module?

I picked up a replacement module today and hope to install & test it tomorrow.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #3 ·
I have the same problem with a 2006.

Did your old module and the replacement respond the same?
Where did you get your replacement module?

I picked up a replacement module today and hope to install & test it tomorrow.
They have the same number on the bracket I got a used one off E-bay .... it was a bit late when I installed today so I will try to check other things tomorrow. To be honest I am completely stumped when I add the fobs to the program they cycle through, I even bought a set of replacement fob and even those cycle when programing those too.
 

·
Registered
Joined
·
33 Posts
I replaced the Door Control Receiver (89741-AA020) with the one from the junk yard.

It solved the problem, both fobs are working correctly.

First attempt at programming failed and acted the same as the old module, after 3 tries the first remote programmed and worked perfectly, the second remote programmed after 2 tries. It would seem the remotes don't always program on the first try, make sure to try programming several times. If you still have a problem there is a very good chance it is the module.

On the first module that came with the car I tried programming both remotes about 7 or 8 times each so I am sure that module was bad, but it was responding to programming just not functioning after programming.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #13 ·
I replaced the Door Control Receiver (89741-AA020) with the one from the junk yard.

It solved the problem, both fobs are working correctly.

First attempt at programming failed and acted the same as the old module, after 3 tries the first remote programmed and worked perfectly, the second remote programmed after 2 tries. It would seem the remotes don't always program on the first try, make sure to try programming several times. If you still have a problem there is a very good chance it is the module.

On the first module that came with the car I tried programming both remotes about 7 or 8 times each so I am sure that module was bad, but it was responding to programming just not functioning after programming.
This is fantastic!! .... I went out and checked all fuse everything seemed fine, I will go out and try it a few more times and if it dosent work I will head to my local junk yard and get one. btw how much did you pay for the module at the junk yard ?
Thanks again greatly appreciated, glad you fixed your issue.
 
1 - 15 of 15 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top