Toyota Nation Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Hi All, I’ve got a 2004 hilux 2wd auto 3rz engine with 240k kms. When I bought the car last week it had a high idle once warmed up and it was knocking into gears when selecting. I took the throttle body off and removed and clean the idle air control (found that it was seized shut) and replaced iac gasket and main throttle body gasket. Put it all back together and now it has a low cold idle 500pm even stalls if I don’t put abit of throttle into it. Once warmed it dose idle alittle under spec. I have also replaced plugs oil and fuel filter, checked for air leaks and cleaned out the throttle body. I did also notice some dry moisture around s/plug 3 I’m going to try a wet and dry compression test in the next few days.

If anyone has had similar problems I would love your feed back tia
 

·
Moderator
Joined
·
13,496 Posts
I'm wondering if yer IAC valve motor might be either weak or not working at all since it was seized up. Did you verfy that it worked by applying voltage to the appropriate pins on the IAC valve motor connector? Did it move the valve? Have you tried measuring the resistance of the motor? ;)

Is yer Check Engine light on? If so, what were the exact codes pulled? ;)
 

·
Registered
Joined
·
8 Posts
Discussion Starter #3
Thanks I’ll see if I can find a tutorial on how to check it and No I haven’t checked the iac moter, if I can’t figure it out I will take it down the auto elec guys and get them to test it for me. I’m not to familiar with multimeters.

No engine light as well
 
1 - 3 of 3 Posts
Top