Toyota Nation Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
:welcome: Thanks for taking a look at my problem.

I just purchased a V6 Alitise, 100,000k. When start it revs around 2000 for at least 3-5 mins, then it is fine and revs around 1000 I am sure this is not normal, and when I put it into gear it takes off. My brother a mechanic and thinks it may be the stepper motor sticking, which I have no idea how to locate! I have had the auto serviced and it is okay. What are your expert thoughts, I am not keen to take to a mechanic just yet
 

·
Maven
Joined
·
3,070 Posts
Cheap things you can look at are:
-check vacuum hoses for any broken or leaking lines
-check air filter making sure it is clean
-disconnect the battery for a few minutes to reset the engine computer
 

·
Registered
Joined
·
118 Posts
I also have this issue, mine only has 50k miles, can someone check what RPM their V6 Camry idles at when cold? I also don't have a check engine light, but I've never seen a fuel injected car idle this high when cold. Maybe a throttle position sensor?
 

·
Registered
Joined
·
20 Posts
My Camry also does this. I thought this was normal? Afterward it drives normal. If i let it warm up. If i don't it won't shift to 3rd until it hits like 5k rpm. But only when i do not let it warm up.
 

·
Registered
09 Camry
Joined
·
552 Posts
when it's freezing cold out, i have a habit of letting my car warm up for 3-5 mins... i dont touch the accelerator and it's always 1500-1900ish for the first 30 seconds
 

·
Registered
Joined
·
118 Posts
It just seems to be too high, for too long. I mean, if you're not on the brakes it lunges forward when you put it in gear. Could be dangerous, it's at least annoying as hell.
 
1 - 7 of 7 Posts
Top