Toyota Nation Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Waited a month for it to come, drove it for two days, then it conked out right before the long weekend and it had to be towed to the dealer. The service dept. can't figure out what's wrong with it - can't start it, can't operate the windows, mirrors, radio, etc. What a bummer. Still waiting for some news on what's going on.

Just needed to vent.
 

·
XRS
Joined
·
2,245 Posts
That bites. Keep us updated and let us know what went wrong.
Did it die as you were driving it or did it decide to not just start on you?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
Everything went dead when slowing down to stop at a red light, about ten minutes into the morning drive to work. Latest news is that they are going to put a new ECU in.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
New ECU is in and they got the car started. But now they can't get the check engine light to go off. Apparently the code is reporting problems with the automatic transmission.......but wait a minute....we're driving a stick! What gives??
 

·
Registered
Joined
·
93 Posts
Skul said:
New ECU is in and they got the car started. But now they can't get the check engine light to go off. Apparently the code is reporting problems with the automatic transmission.......but wait a minute....we're driving a stick! What gives??
if it makes you feel better i got a grapefruit too with my XRS
it's over a year old now and they still can't get it right.
:mad:
 

·
Registered
03 Corolla
Joined
·
109 Posts
sorry to hear that man, sure u didn't touch anything by urself aye?
but not to worry warranty will look after..., or u can refund or exchane cuz only 2 weeks old rite?
 

·
Registered
Joined
·
93 Posts
Ok need an Update Please!
What was the root cause, and is your ride fixed completely now?
give us a status update, let us know what is going down!
 

·
Registered
Joined
·
4 Posts
Discussion Starter #9 (Edited)
Finally got our ride back. Apparently there's a bad batch of ECU's that got past quality control. After trying to put in a new one without success, it was discovered that Toyota Canada had labelled it for manual transmission when it was actually for automatic (at least that's what the dealer says). Once they figured that out, they had to order the right one. But by that time, the ECU was on backorder, so we had to wait for what felt like forever. So they finally got the right one in, and it's been working fine for two days (knock on wood). But now we have to bring it back in to get them to repair a gouge they made on the dash, a scuff they made on the door, and a horrible rattle behind the glovebox that wasn't there when we first got it. This is all sooo bloody frustrating!

And no, we didn't try any mods before all this started, and will be holding up on doing anything until we know for sure that this car won't crap out again. The only thing we've done so far is to replace the whimpy horn with something that doesn't embarass us to use.
 

·
Registered
Joined
·
17 Posts
ECU?

Would the ECU be the computer?? My 2004 Matrix is 9 months old. Used it @ 11pm on Friday. Sat morn it wouldn't start. Turned over but wouldn't crank. Had it towed in on 10/16. By 10/19 they finally solved the mystery.... It needs a new computer. Okayyyyyyy so I wait. They said it would be in by 10/21 & still I wait...... I just called them & got put off so now I'm waiting for the GM to call. I loved my car. It's fun & practical. Now I'm concerned & "expecting" rattles from them pulling chit out.
 

·
Registered
Joined
·
17 Posts
Yep it was the computer. Its an automatic. After rattling Toyota's cage yesterday lo & behold my car was ready last night. So far so good. The only thing I've noticed different is that it STARTS and it now beeps when I set the alarm. We'll see..........
 

·
Registered
Joined
·
17 Posts
OK its been a few days & I'm happy again. They didn't leave me with any rattles. They remembered to do my 7K mi service & its running great. :D Went out today & detailed it. Feelin much betta now. My confidence in Toyota is restored..........
 

·
Registered
Joined
·
93 Posts
mcnana said:
OK its been a few days & I'm happy again. They didn't leave me with any rattles. They remembered to do my 7K mi service & its running great. :D Went out today & detailed it. Feelin much betta now. My confidence in Toyota is restored..........
Same here mines running fine since they did all the work on it. Faith has been restored in Toyota as well
 
1 - 15 of 15 Posts
Top