Toyota Nation Forum banner

41 - 60 of 64 Posts

·
Not-So-New TN User
Joined
·
5,565 Posts
its for the Sport shift


I guess my circle was unclear. I got my odometer yesterday and took everything apart. I'm referring to the red arrow, not the blue arrow. I'm not convinced its for the hybrid model. My rectangle came blank and the pcb board had empty solder pads for leds. Also I got a 2010 cluster and the gauges are also raised, not flat like you said.
 

·
Registered
Joined
·
316 Posts
sorry for bump up, but if anyone plan to perform this mod on a CE/Base or LE model, i have bad news to deliver....
THIS MOD WILL NOT WORK WITH LE

After spending 200bucks for a XLE cluster, Right side DISP only switch from highlander sport and few hours of hard work nightmare, i can confirm LE have no Violet/silver wire at either slot 22 or 23...... that means my display will never work, if anyone need pics to prove, i will happily upload them soon since my phone were dead after a friday afternoon nightmare, first the cluster didnt work, second my HID kit arrive with only 1 ballast working. pin 3 is also empty on LE model i can confirm

my camry LE were a 4 cylinder and build in Japan on feb, 2007. i hightly suspect that toyota have 2 set of tooling, one of them for XLE/SE and another set for LE/CE, since LE has lots of prewiring taken out, such as foglight.....

If anyone have perform this mod on a 4 cylinder SE or 6 cylinder LE, please report so we can know if my guessing are true


p.s: i now have a 4 cylinder XLE cluster for sale, if anyone interests please let me know
 

·
Registered
Joined
·
134 Posts
sorry for bump up, but if anyone plan to perform this mod on a CE/Base or LE model, i have bad news to deliver....
THIS MOD WILL NOT WORK WITH LE

After spending 200bucks for a XLE cluster, Right side DISP only switch from highlander sport and few hours of hard work nightmare, i can confirm LE have no Violet/silver wire at either slot 22 or 23...... that means my display will never work, if anyone need pics to prove, i will happily upload them soon since my phone were dead after a friday afternoon nightmare, first the cluster didnt work, second my HID kit arrive with only 1 ballast working. pin 3 is also empty on LE model i can confirm

my camry LE were a 4 cylinder and build in Japan on feb, 2007. i hightly suspect that toyota have 2 set of tooling, one of them for XLE/SE and another set for LE/CE, since LE has lots of prewiring taken out, such as foglight.....

If anyone have perform this mod on a 4 cylinder SE or 6 cylinder LE, please report so we can know if my guessing are true


p.s: i now have a 4 cylinder XLE cluster for sale, if anyone interests please let me know
Had trouble understanding, why are you messing with Pin 22? Just run a Jumper from #23 Cluster to #3 clock spring. Thats all end of story
 

·
Registered
Joined
·
316 Posts
Had trouble understanding, why are you messing with Pin 22? Just run a Jumper from #23 Cluster to #3 clock spring. Thats all end of story
I have read all the post above, i remember some of the pic mentioned pin 22 or 23 is the violet silver wire, but when i tried to perform this mod 2 days ago, my LE have no Violet/silver wire in either slot 22 or 23, this is why i make the post above, so the conversion u or bailey mention will not work with CE or LE
 

·
Registered
Joined
·
120 Posts
Discussion Starter #52 (Edited)
What porn-adkt said. Just run a wire from the cluster straight to the clock spring if you need to. It’s been years since I’ve done it, but sometimes you need to wing it when things don’t seem 100% as described from others.


Had trouble understanding, why are you messing with Pin 22? Just run a Jumper from #23 Cluster to #3 clock spring. Thats all end of story
 

·
Not-So-New TN User
Joined
·
5,565 Posts

·
Registered
Joined
·
11 Posts
2010 Camry LE with a 2011 Camry XLE Instrument cluster.
I'm having issues getting the DISP button to work.

See attachments for the cable I ran, originally these PINS were empty so I ran the following on the clock spring PIN 3 is a green wire. For the instrument cluster PIN 22 is a white wire and PIN 23 is a red wire. I've tried the green cable on PIN 3 to both PIN 22 and PIN 23. Neither seem to have any effect on the display on the cluster.
 

Attachments

·
Registered
Joined
·
11 Posts
Got this working on the 2010 Camry LE, this is what I discovered is that not only do you need to run a wire from pin 3 on the spiral cable but also need to run another wire from pin 9 on the spiral cable. This wire needs to go to ground.
 

Attachments

·
Registered
Joined
·
404 Posts
I have a 07 LE and swapped in a 09 XLE cluster. There's a constant warning on the cluster lcd that the hood is opened. I think only XLE Camry has the latch with built in sensor. Anyone had this problem and way to bypass it?

Update: OK I figured it out. Just ground the wiring sensor and the warning is gone.
 
41 - 60 of 64 Posts
Top