Toyota Nation Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter · #1 ·
I’m working on my 21 year old daughters 2009 Toyota Camry se 3.5. It has the jbl factory sound system. It only has sound out of the dash and rear trunk speakers. The door speakers are not working at all. The sound is very weak no bass at all like maybe the amp is not working. It’s like the car only has tweeters for speakers. Anyone know what I could do to fix this? Any help would greatly be appreciated.
 

·
Registered
Camry XLE, V6
Joined
·
23 Posts
If your rear speaker doesn't have bass, it's possible that the amp is gone (adjust control nob to only rear speaker to see if sound has bass). JBL system has separate crossover wire to the speaker for low and high freq. If the speaker didn't blow out, time to buy a new amp.
 

·
Registered
Joined
·
130 Posts
I think amp is under dash a new one will be expensive most factory stuff is try junk yards first pull a part first as they are cheapest if you have one near by. Search google amp location it will show you.
 

·
Super Moderator
2020 Prius Prime Limited
Joined
·
5,053 Posts
according to this video under glove box link to video.

That's for the 2002 - 2006 according to the video info. OP indicates he has a 2009. There is no JBL amp under the dash in the 2009 Camry, it is under the passenger seat.
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top