Toyota Nation Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
My daughter just was given a 2009 Corolla LE with a 1.8l and it has some issues. ABS and CEL light are on, as well as the VSC and emergency brake light. OBD2 scanner posted both driver and passenger front speed sensors as being bad, replaced both and also threw a P0500 code and I replaced the speed sensor on top of the tranny housing. Took it for spin and threw all the same codes and dummy lights. I thought there were two speed sensors on the tranny housing but everywhere I searched it shows just one. Didn't there used to be a output shaft sensor with a small plastic gear that slid into the case? I'm at my wits end, she is about to get her permit and I can't even get the thing inspected because of the codes/CEL light. Thoughts?
 

·
Moderator
1995 T100 2WD & 1993 MR2
Joined
·
4,855 Posts
Is the VSC still on. Reset your maint. reminder if it has one. 2 VSS, LF and RF.
 

·
Registered
05 camry 07 tacoma
Joined
·
2,877 Posts
Can you post all the error codes you currently have?
P0500 was first set along with the other codes ?
 

·
Registered
05 camry 07 tacoma
Joined
·
2,877 Posts
Regarding the P0500 does the speedometer work?
The C0200/C0205 if wheel speed sensor good then circuit or PCM faulty.
Alldata.com has good wiring diagram/testing procedure and explanation for the error codes.
 

·
Registered
05 camry 07 tacoma
Joined
·
2,877 Posts
Yes, believe so. You may have changed the TC, input sensor.
The output sensor probably more hidden and think is magnetic and not like the old mechanical gear sensors.
Check out the alldata as i am just going buy my 05 Camry VSS.
 
1 - 9 of 9 Posts
Top