Toyota Nation Forum banner
1 - 4 of 4 Posts

·
Just duct tape it!
Joined
·
612 Posts
Discussion Starter · #1 · (Edited)
Can anyone explain what this is??? 2AR-FE motor.

50k miles on it. Just got it. Does this on cold starts (or sitting for 2 or so hours).

Seems like it goes away 90% after its 100% fully warmed up. Like after 10 minutes of driving.

Noise is louder under load. (driving with light throttle or ebrake and light throttle in gear).


Fresh oil change. Tried premium gas, no change. Carfax shows its had its services and oil changes.
 

·
Registered
Corolla, Camry, Tundra, Camry, Avalon, Highlander, Venza, Highlander
Joined
·
4,391 Posts
Don't buy a car with an engine that noisy without making adjustment in the price to offset the engine replacement.

Carfax shows what? 20k oil changes or 3k oil changes?
Carfax won't show that the previous owner ran it out of oil prior to every oil change.

What oil and filter did you use since "fresh" means nothing?

Normal piston slap on a cold Toyota with a little rod knock caused by previous oil starvation wear/tear.

I would pull a valve cover or oil pan for inspection. If no sludge, change the oil and filter as needed and keep driving.

As you increase the stereo volume, the noise should go away.
 

·
Just duct tape it!
Joined
·
612 Posts
Discussion Starter · #3 ·
Well, problem fixed.

I got Toyota to take it back for full purchase price. I upgraded to a 2013. Much happier now. This one sounds like it should. I know its the same motor. This one is certified pre owned and only 30k miles on it. Got a good deal on it.
 

·
Registered
2009 V6 RAV4
Joined
·
861 Posts
My 4cyl '98 Camry piston slapped on cold starts like that for years and it never developped into a full fledged problem.

My 2009 V6 Rav4 piston slaps like that when cold, goes away when warm.

It sure is annoying
 
1 - 4 of 4 Posts
Top