Toyota Nation Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
This is a new 2022 RAV4 Hybrid with 350 miles on it. Made in USA. The vehicle has a smart key system for locking/unlocking and starting. The system includes two key fobs and a connected app that can lock/unlock and start the vehicle. The car also has a touch sensor on the door handle to lock/unlock the vehicle when the key fob is present.

Two scenarios/types of behavior:

1. After driving, vehicle won't lock/unlock with anything but the hard key (fob, door handle touch sensors, connected app, interior lock buttons don't work). Issue appears to go away after restarting vehicle. Other electronics work when this happens.

2. After being parked for ~1 to 24 hours, the vehicle won't unlock or start at all. The only way I've been able to "reset" is to attempt to shift out of park, which activates the alarm, which reactivates the fob/connected app.

During both scenarios: cabin lights work, some dashboard indicators work (like door open/closed diagram).

App error message
If I try to lock/unlock or start the vehicle with the connected app while this issue is happening, I get the following error message: "2022 RAV4 Hybrid: Your request could not be completed due to a communication error. Please try again later. [C2]"

Issue history

The first time this happened, I was trying to drive the car off the dealership lot and it wouldn't lock/unlock or start. The dealership said they reprogrammed the keys and that it solved the issue.

Then, a few days later, I had just finished a ~10 mile drive, turned the vehicle off, and was trying to lock the vehicle by pressing the touch sensor on the door handle and nothing happened. Then I tried the key fob and nothing worked (lock/unlock, lift gate, alarm). Then I tried the lock button inside the vehicle and it wouldn't work. I was able to restart the vehicle by pressing the start button, after which the fob worked again.

A few days later, the vehicle had been parked for 12 hours outside my apartment (I live in California and temps were about 50 degrees overnight and 60 during the day). The vehicle wouldn't lock/unlock or start. I could only resolve the issue by attempting to shift out of park, triggering the alarm, and then using the fob.

Both of these types of scenarios happen several times a week.

Things I've tried
Disconnecting 12V battery for an hour and overnight

Checking 12V battery health

Starting with just 1 fob present

Starting with both fobs present

Re-installing all apps

Reprogramming keys

Touching fobs to start button

Dealership involvement
I have taken the car into two different dealerships three different times.

Most recently, the vehicle stayed with them for 10 days, during which time they supposedly turn the vehicle on/off and locked/unlocked multiple times a day trying to recreate the issue. They weren't able to.

The dealership submitted a ticket to their global system to see if they could find a similar issue but found nothing.

Both dealerships have suggested that it's user error and that I should learn to use the key fob better.

One of the techs at the dealership that I spoke with suggested that it could be interference from something like 5G and that I should consider getting a new set of keys programmed to the vehicle. When I suggested this to my dealership service rep, he said "not unless we can observe the issue".

Please help!
I don't know what to do at this point. I still get the issue regularly and don't know how to help the dealership observe it.

I'm thinking about buying a diagnostic tool so I can get a snapshot of the system when this issue happens, but I know nothing about car diagnostics. Would appreciate some guidance in this area.

Thanks in advance for your help!
 

·
Premium Member
2021 Avalon XSE Hybrid
Joined
·
6,943 Posts
Ask the dealerships to instruct you on how to properly use the system if they claim it is user error. This is a service that should be provided at the time of purchase.
Duplicate the problem for the dealer.

A new set of keys is not going to resolve any interference issues.

This almost sounds like the battery in the fob may be weak, or an intermittent problem with the fob, but that it's happening with two fobs makes it look like an issue with the vehicle, or some other external issue, but that it's not responding as expected to the app points to the vehicle itself.
 
1 - 2 of 2 Posts
Top