Toyota Nation Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have a 22re with normal operating temp issues. It starts fine when cold and will drive down the road . If you shut it down and try to restart all it does is crank over. let it set for 30 min to an hour and it will start right up. There is a fuel supply issue. If fuel is sprayed in the intake it fires right over. The fuel system has been over hauled new pump filters relays and and fuel pressure regulator. Any and all help is appreciated.
 

·
Registered
Joined
·
3 Posts
I have a 22re with normal operating temp issues. It starts fine when cold and will drive down the road . If you shut it down and try to restart all it does is crank over. let it set for 30 min to an hour and it will start right up. There is a fuel supply issue. If fuel is sprayed in the intake it fires right over. The fuel system has been over hauled new pump filters relays and and fuel pressure regulator. Any and all help is appreciated.
Hi, I’m currently going through identical issues with my ‘94 pickup. I had checked, tested, or replaced: battery, cables(including all engine grounding), starter, distributor and wiring, coil, EFI relay, visual checked ECM motherboard, and replaced fuel injectors( did eliminate an idle miss and also accelerates a lot harder). None of these have fixed the problem and I am now leaning towards checking the fuel system, lol, then if no luck, on to testing the wiring harness.
 
1 - 3 of 3 Posts
Top