Toyota Nation Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
295 Posts
Discussion Starter · #1 ·
so my ebrake light and my batter light come on at the same time...usually when the motor is cold
thats a charging issue right? gotta double check all my ground wires. those lights come on and my battery gauge jumps to 18v tonight my hids went out but i pulled over and my headlights came back on and battery light and ebrake light went off?? idk what it could be?

also when i drive or at idle when i step on my gas pedal it takes a while for the rev to come back down?
i step on the gas rev to 2k and let off the gas but it takes a while for the rpms to drop back down? i pulled the slack off the throttle cable adjusted idle idk what else it could be. when i drive lets say first gear i step in the clutch and the truck still revs at 2k rpms doesnt drop it takes a while....

any advice is great i tried searching some stuff but im still confused. this is my first 22re ive only owned toyota 3.0s hahaha thanks in advance

aloha
 

·
Soylent Green sales
rock crawler
Joined
·
12,801 Posts
When both lights come On it means an alternator problem.
It usually means worn brushes, but your symptoms are a bit different from the norm.
You might want to pull the alt and have it bench tested for load and regulation.
 

·
Registered
Joined
·
295 Posts
Discussion Starter · #3 ·
^^ yeah its a bit weird...i know that the alt has a lot of gunk on it. i have some electrical cleaner stuff that im gonna try and clean it down with.

oh and i googled to look for all my ground wires, and my alt ground wasn't even hooked up. so i grounded the wire and only now those lights have been coming on?
 

·
Registered
Joined
·
295 Posts
Discussion Starter · #4 ·
ok so i think I got my charging issue under control...

gonna try n figure out my throttle issue today...

also i got this nasty leak...it's all over the front end of the motor and only on the passenger side? the drivers side is clean...checked my dip stick oil is perfect oil press gauge works fine idk what this fluid is but it leaks quite a bit all over the alt, lower rad hose, water pump, ac, driving me crazy
 

·
Soylent Green sales
rock crawler
Joined
·
12,801 Posts
idk what this fluid is but it leaks quite a bit all over the alt
Is it red like ATF?





If so, check the level of the PS fluid, the resevoir is on the inner fender, drivers side.
 

·
Registered
Joined
·
295 Posts
Discussion Starter · #6 ·
no it's like motor oil but all black n grimey...ps was bone dry when I got it refilled and now it's fine do i gotta bleed the power steering system
 
1 - 6 of 6 Posts
Top