Toyota Nation Forum banner

21 - 23 of 23 Posts

·
Registered
Joined
·
1 Posts
Toyota thumb knock

I read all your symtoms on your 3.4L & I have the exact same ones down to a tee...did you ever find the problem?
I am a mechanic & some of the things they charged you to replace I have done and do to all my vehicles when I buy a used vehicle...
I get and have gotten alot of the same suggestions & they are just that...simple suggestions that are parts changes but do not or will not solve this problem...
I will be checking the main bearings today..( rod bearings look great )

I will alsso attempt to ck wrisk bearings & crackes in pistons as well as piston slap....I use the word attemp because this is hard to do with out talking pistons out...
Please tell me if you or anyone else has found the solution to this problem.
 

·
Registered
Joined
·
2 Posts
I have a 2003 Tacoma Pre-runner with V-6. The timing belt broke at 160,000 miles. We replaced timing belt and water pump but it had a "tick" in the motor. We thought it may have bent a valve or something, but it ran great so we never fixed it. It now has 391,000 miles on it and just today ran a little hot And is knocking real bad. Anyway we ran ours with noise for 0ver 200,000 miles with no motor problems till now. We use this truck for an oversize load escort vehicle. Very hard miles and very little maintenance. I hope you get the same reliability out of your truck. I love mine. If I could afford it I would get another motor for it because it sounds bad now but we'll just have to see what happens. Hope this helps you feel better about your truck. Thanks.
 
21 - 23 of 23 Posts
Top