Toyota Nation Forum banner
1 - 6 of 6 Posts

·
92 Toyota 4x4 SR5
92 ExtaCab/SR5
Joined
·
9 Posts
Discussion Starter · #1 ·
I have a 92 toyota pickup 4x4 SR5 3.0L. I am having some issuses with my four wheel drive, with A.D.D. Befor i put on warn premium hubs, when ever i would shift in 4x4 it would sometimes pull off to the the right on dry pavement but not all the time... After i put on the hubs it did it all the time.. I have just rebuilt my front axle with new barrings, seals and put a lockright locker in it, i also put new CV axles and front u joints in.. but its still doing it. i have tried everything i can think of.. i took off the right hand side hub to see if it would stop, it didnt.. The only abnormal thing it does is when i put it in 4x4, i have to keep good steady pressure on the sterring wheel. and to turn left it is very hard to turn.. Or when i am fighting it to keep it stright if i let go of the wheel it turns to the right imediatly. I put enough pressure on the wheel that if i drive it for a coupple of block (only about 10-15 MPH) it starts to speaw out powersteering fluid. The only other thing i could think of is that my front and rear axles are differnet ratios. but it wouldnet favor one side?? Can someone help me out??
 

·
Registered
Joined
·
134 Posts
dude... 4 wheel drive on dry pavement = very bad.

I think if you had different ratios it would do that.
 

·
92 Toyota 4x4 SR5
92 ExtaCab/SR5
Joined
·
9 Posts
Discussion Starter · #3 ·
its just kinda weird that when i put on the new hubs i tested it on dry pavement and it didnt do it... thank you for the input though
 

·
Soylent Green sales
rock crawler
Joined
·
12,801 Posts
Dude, you have part time 4WD, it's not meant for dry, hard pavement at all.

Any problems you think you may have on dry hard pavement in 4WD are meaningless.

Try your 4WD on some slippery terrain and see what happens.
 

·
92 Toyota 4x4 SR5
92 ExtaCab/SR5
Joined
·
9 Posts
Discussion Starter · #5 ·
i would but i am in a stupid city right now.. i wish i was back in alaska. i noticed that when i turn all the way right or left it would smooth out. i have a leak on the passenger side intermediate shaft. I installed the new seal and snap ring. but it can move about 1/4 in of movement? is that normal.. i think that i got the seal in right it countersunck about 1/8 in below flush. i think that the intermediate shaft is to long and it dosent sit in the locker right. any body have the same issue on a 7.5 diff??
 

·
Registered
94 pickup
Joined
·
129 Posts
check your tire pressures. if they're off, it could cause the symtoms your discribing
 
1 - 6 of 6 Posts
Top