Toyota Nation Forum banner

1 - 7 of 7 Posts

·
Registered
1981 toyota 4x4
Joined
·
5 Posts
Discussion Starter #1
i have a 81 toyota 4x4 with a 22r with 20R head bored .030 over with a ('92?) corola carberator had a electric choke and a L50 transmission. the problem i am having is that when i start the engine it acts like it wants to stumble and die if you touch the accerlarator after you start it. i thought it was the choke so i replaced it with a manual choke and that solve it when the engine is choked but when i push the choke in the problem returns and the only way to solve it is after i shift gears is to pull on the choke to regain acceleration and to stop the stumbling i fell it might be out of adjustment but i wanted to tap the resources of people wiser than me. the engine also feels under powered in all gears and i wanted to know what could solve that alement.
 

·
Corona is gone.
86 Pickup
Joined
·
863 Posts
Check for vacuum leaks around the carb. Why do you have a 92 Corolla carb on your engine?
 

·
King Dingaling
77 scottsdale 4X4
Joined
·
129 Posts
sounds exactly like a vac leak. trick I used to use is to spray starter fluid around all the mating surfaces and vaccume hoses. if the engine reved a bit then thats where my vac leak was.

and I'm not sure but I think the last carb off the assebily lines was in 1988 for the 'rolla
 

·
Corona is gone.
86 Pickup
Joined
·
863 Posts
You still did say why you have a Corolla carb on it.
 

·
Registered
1981 toyota 4x4
Joined
·
5 Posts
Discussion Starter #6
yes cause that is what i was told that it was the (?) meant that i wasnt sure of the year or model car i know that they went to efi but i dont kno what models or years i only deal with the trucks from 79-85. and the carb came off of a 22r motor the yellow sticker has "toy 500" on a metal piece near the butterflys under the airfilter.
 

·
Corona is gone.
86 Pickup
Joined
·
863 Posts
So did someone rig this thing before you got it?
 
1 - 7 of 7 Posts
Top