Toyota Nation Forum banner
1 - 5 of 5 Posts

·
Registered
1985 Toyota Pickup
Joined
·
63 Posts
Discussion Starter · #1 ·
THe toyota ac on my 85 truck is blowing just a little cold air. I have tried adjusting the amplifier but cant get it to blow cold. I think the freon level is fine. Cant figure out where the magnetic clutch is, guess on the compressor? Also cant figure out where the temperature adjusting screw is. The toyota manual says it is near the "compressor cut off adjusting nob" (guess this is the same adjusting screw on the amplifier?).

Thanks for your help.
 

·
Registered
Joined
·
1,213 Posts
If the refrigerant sight glass is foamy when you turn on the compressor, then you are low on R12 freon and cooling will be weak.
 

·
Registered
1985 Toyota Pickup
Joined
·
63 Posts
Discussion Starter · #3 ·
thanks, will check it out. Tried to see the sight glass the other day but the receiver is dirty and hard to get at to clean.
 

·
Registered
1985 Toyota Pickup
Joined
·
63 Posts
Discussion Starter · #4 ·
I cleaned off the site glass and tried running the ac. Could not get the compressor to kick on. I tried adjusting the amplifier to get the compressor to kick on, but it would not.

will keep trying to get the compressor to come on to check the make up of the freon.
 

·
OLD SCHOOL
2003 Tacoma pre-run
Joined
·
668 Posts
if the system is low on freon the compressor may never come on. The magnetic clutch is the rather large and over sized pulley around the compressor front of the coompressor and the clutch is inside
 
1 - 5 of 5 Posts
Top