Toyota Nation Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
My 91 starts and runs for about 3 sec. and then stops, it will do this repeatedly. Got spark, got fuel, changed the ignitor, don't know if the second ignitor is good either,it was used. tryed another distibutor, checked for wires being shorted . could it be the computer. I was told they hardly ever go on a toyta pick-up. I,m stumped , help.
 

·
Registered
Joined
·
1,750 Posts
About half of the ECU codes stored on the first & second generation EFI Toyotas don't show a constant blinking check engine light therefore you must pull the ECU codes and auto tranny computer codes to see if a fault is registered.
To pull the ECU codes:

All 1980-1995 and including 1995 EFI equipped vehicle allow you to find engine and related faults by pulling the ECU (computer) codes without the need for a handheld OBDII diagnosis scanner,the sites listed below have the fault codes needed to pull the codes and the instructions on how to do it:

http://www.off-road.com/toyota/tech/codes/index.html
http://www.geocities.com/MotorCity/Pit/9975/dataBySubject/Engine.html
http://www.mad-mechanic.com/toyota/toyotaobd.shtml#obtaincode
http://www.freewebs.com/th3duke/22RE-ECU.mht
http://www.troublecodes.net/Toyota/
http://members.igateway.net/~pscott/enginecodes.html
http://www.troublecodes.net/Toyota/
http://www.showmesome.info/hilux/info/manuals/1KZ-TE/Page0096.htm
http://www.efisakh.narod.ru/at_toyota.htm
http://www.usatransdoctor.com/foreigntoyota.htm
http://www.autobook.co.kr/data_links/toyota_trouble_codes.htm
http://www.ecutecparts.com/ccodes/toyota.html
http://www.autoshop101.com/forms/h27.pdf
http://autorepair.about.com/library/ts/obd-i/bl-dtcs-36.htm
http://autorepair.about.com/library/ts/obd-i/bl-dtcs-53.htm
http://autorepair.about.com/library/ts/obd-i/bl-dtcs-71.htm
http://autorepair.about.com/library/ts/obd-i/bl-dtcs-90.htm

Pulling the ECU codes is the first thing I do to diagnosis a problem thereafter I reset the ECU to see if the same problems show up and if so I then take voltage measurements both with the engine running and not and compare with the factory service manual,I also close the ignition switch after a cold engine and also after a warm engine and compare them with the factory service manual.This technique will completely isolate your problem without having to do trial and error and it is the technique I use when repairing tv's,vcr's,home/car audio.

Any public library in your area would have the Factory service manual,Haynes,Chiltons,Mitchells and Toyota repair books.
There is also free AutoZone service manuals at:

http://www1.autozone.com/servlet/UiBroker?ForwardPage=/az/repair_info/repair_guide/repair_guide.jsp

For scanned pages of factory service manuals for other engines:

http://www.brian894x4.com/Scannedmanual.html
http://www.showmesome.info/hilux/info/manuals/1KZ-TE
http://toyoefi.freeyellow.com/manual.html
http://perso.wanadoo.fr/adherence.4x4/liens_techniques.htm
http://perso.wanadoo.fr/adherence.4x4/index.htm
http://www.asatraction4x4.cl/html/
http://www.grubinski.com/grubinski/manuals.html
http://www.hotrodder.com/kwkride/tech.html
http://www.autoshop101.com
http://www.mtv411.com/sitemap.htm

Free 2003 Toyota Tacoma Factory Service Manual download:

http://www.junglecode.com/toyota/tacoma/2003_fsm/

Sidney
Repairs tv's,vcr's,home/car audio out of my home
E-mail:sidneybek(at)yahoo.com
Dartmouth,Nova Scotia
Canada
1985 Toyota 4-Runner,22R-E,W56,RN60LV-MSEK,rusted rear step/towing chrome bumper with 241 000 KM


:kingme:
 

·
Registered
Joined
·
9 Posts
Discussion Starter #3
I did get codes they were 12,13 ,14 43 they indicate something to do with the rpm signal, which pointed me to the ignitor , then possibly the computer.
 

·
Registered
Joined
·
1,750 Posts
Again take your DMM and measure the voltage and resistances at the ECU and compare with the factory service manual.

Repairs tv's,vcr's,home/car audio out of my home
E-mail:sidneybek(at)yahoo.com
Dartmouth,Nova Scotia
Canada
1985 Toyota 4-Runner,22R-E,W56,RN60LV-MSEK,rusted rear step/towing chrome bumper with 241 000 KM

:hammer:
 

·
Registered
Joined
·
9 Posts
Discussion Starter #5
This truck will not run long enough to get a warm reading. All I really need to know is if someone else ran into this problem, and what was the fix. Trying to find the electrical problems in the mess of wires they put into today's vehicles can drive you nuts .
 

·
Registered
Joined
·
341 Posts
well, if you're gonna use sidney's tv vcr repair technique, I would start by replacing the Distributor. after first checking it's connectors and checking open circuit v. of course. actually, you should clear the codes then crank the RE a couple of times and see if the cel and codes come back. just to verify that the codes you pulled are current and not old codes stored in memory.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #7
All that checks out, it seems as though the fuel isn,t getting to the injectors, I pumped fuel into the intake and it kept running until I stopped. The fuel pump seems to have plenty of pressure. The next thing is to see if the pulse signal is at the injectors, if it is then something is restricting the fuel. It seems like I,m diagnosing this myself.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #8
Here's the latest, I have spark, I have 38lbs. of fuel pressure at the rail, checked all the relays, I have power to the injecters, but I didn't check for pulse. There is 12volts of power to both sides of the injecter plug. Is this normal? I'm checking for shorts, I still wonder if it can still be the computer. What do ya's think.
 

·
NY born, Texas raised
Joined
·
705 Posts
12v to both side of injector does not sound good. Need ground on 1 side to make the circuit. Sounds like a good one. Good luck.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #10
Well if it's a computer, do you know where I can find one reasonable just incase I'm wrong , I don't want to sink much more into this. The computer number is 89661-35640. Thanks if anyone can help.
 

·
Registered
Avalon
Joined
·
262 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #12
Well I located a computer, I'm waiting for ups to show up with it. Let ya know what happens when I hook up. If this doesn't work , I might have to put this beast down.:lol:
 

·
Registered
Joined
·
9 Posts
Discussion Starter #13
The problem is solved , it was the mas air flow , it never gave a code for it either. I had an extra one , but never tryed it because the symptoms just didn't point to that. Thanks .
 
1 - 13 of 13 Posts
Top