Toyota Nation Forum banner

'91 Pickup - Starts then immediately stalls

23709 Views 4 Replies 4 Participants Last post by  LTD
Hello and thanks in advance for your help. Recently my thermostat started sticking. About 3 days before changing it, this stalling issue started. The car will start but stalls immediately. The first few times it happened, if I tried to start it 3-4 times, it would start and keep running (not well, but that was due to the thermostat issue). After a few days, it would start, but always stall immediately.

I did get it running once, and drove it around for 30 min, it worked fine. One other time it started and ran for about 10 min before stalling. Those are the only two times.

Last interesting thing about this issue. If I start the car and hold the ignition switch in the "start" position, the car will keep running until I release it (although the starter whines, and im sure this isn't the best thing for it).

So far I've:

1. Changed the thermostat (to fix the original issues I was having)
2. checked all wiring harnesses under the hood
3. cleaned the MAF w/ MAF sensor cleaner
4. checked for leaks in the intake

I'm at my wits end, any help/advise would be super appreciated!
1 - 5 of 5 Posts
It sounds like your gas is cutting off. Check the fuel supply. Replace the fuel filter if you have not done it in a while. There could be many factors creating this problem, but if you hold the ignition and it keeps running, it sounds like the power to the fuel pump may be getting interrupted when you release the start switch.....

I bought a 91 22re 4x4 M5 standard cab that I've been slowly correcting the previous owners (botched) repairs. I found a wire jumpering the Opt and Tt ports (the two outside ports closest to the firewall) in the little grey diagnostic box. When I pulled the jumper the truck would fire and almost immediately stall. It would literally run for a second and than die. I put the jumper back in across the two ports and it fires right up and runs great again. I've put 3500 miles on it (who knows how many before me) in this condition and haven't had a problem. I'm not suggesting this for a fix as I'm not sure what exactly this is bypassing, but I think I have the same problem (with jumper removed) as you.

I haven't had a chance to really dive into this particular issue (as its running good) but I think its bypassing some fuel relay/switch/connection as the fuel system obviously works (filter, pump etc...) if its running good it has to be an electrical issue that the above ports bypass. If anybody knows what this little jumper trick "fixes" maybe they can help both of us out. Thanks
See less See more
boy have I had this problem; jumpimg the two the two ports at the gray box is bypassing the feul pump relay, once it's bypassed you should here the pump run. is it does, the afm is probbly the problem. i took the black cover off the afm and the 1st & the 2nd terminal to the back or right side are the fuel to the fuel pump. in my case they would not make contact once the motor starts to run (push the 2 together and the pump should run) I had my wife start the truck as i looked at the afm then with my finger i tweecked it so it made contact as the dial rotates.
  • Like
Reactions: 1

Beechbum thanks that did the trick the little arm that pushes on term#1 was hitting #2 couldn't get by and they were all bent to S%$T. Guess I should have looked up AFM with the search function but didn't even think to look at the AFM. I think you saved me a few bucks in parts. No more jumper I feel much better about driving around now (gunna hold on to the jumper just in case though). Thanks again.
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.