Toyota Nation Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
So I was driving on the freeway and my truck shut off and hasent started since. I have no spark coming out of the coil, but do have power to the coil. tested the ignitor, and acutally replaced it, it did not fix the problem. trying to test the ecu for the ignitor signal, but have bad info. any ideas on what to look for coming out of the ecu???
 

·
TOYsRus
11Tundra Limited TRD
Joined
·
144 Posts
Short guess if you are getting fuel (seeing you already checked spark) is the timing chain if 22RE and Chain if V6
 

·
30YRTOYOTAPARTSEXPERINCE
04 Camry; 09 Sienna
Joined
·
1,237 Posts
Did you replace the coil with the igniter. Also check the lead that goes into the distributer. It is what the igniter connect too. If that is bad, you may have to replace the distributor or distributor housing. That is the only way to get that part inside the distributor.


Short guess if you are getting fuel (seeing you already checked spark) is the timing chain if 22RE and Chain if V6
 

·
Cruiser Innovations
FJ55 TLC
Joined
·
3 Posts
Did you replace the coil with the igniter. Also check the lead that goes into the distributer. It is what the igniter connect too. If that is bad, you may have to replace the distributor or distributor housing. That is the only way to get that part inside the distributor.
:thumbsup:
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top