Toyota Nation Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Ok, so my 92 2wd 22re 5-speed has came down with a case of the rattles. It is pretty bad at an idle and goes away at highway speeds only to return under a load or at idle. I had the timing chain, guides, oil pump, and water pump replaced two years ago. I haven't adjusted the valves since they were adjusted with the new tc. the truck has 340,000 on it but still runs like a champ. Any help would be appreciated, I would rather start simple in hope of a cheap easy fix. I'm taking off the water pump belt to see if that changes anything and then a/c and smog belt. Sounds like its in the front/top of the motor.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #2
Checked it with a broom stick and my ear, its coming from the front of the motor.
Could possibly be the bearing in the water pump but I'm betting on the tc guides.
smh.. should've bought the metal ones. I will update more when I get further along so maybe, I CAN HELP SOMEONE WITH THEIR PROBLEM IN THE FUTURE.
 

·
Soylent Green sales
rock crawler
Joined
·
12,801 Posts
Let us know how it goes, problems like that can be hard to figure out.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #4
Tore the valve cover off and.... timing chain guide on driver side has disappeared.
I replaced the chain, guides, oil pump and water pump three years ago. I've had a slight rattle the last year or so, Im assuming the plastic guides didn't hold up as long as I had thought. Moral of the story: spend the extra $, buy the timing chain kit with metal guides or throw time/money away every 70,000 miles.
 
1 - 4 of 4 Posts
Top