Toyota Nation Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hey all, just have an issue with my Tercel with A/C not working. Previous owners said they re-did the air conditioning fluid a few years before I bought the car from them, so around 99'. But its never worked that good, and right now it does not work period. I'll push the green button for A/C, and the green LED comes on, but I swear its not connected to anything because it does not make one single difference. Anybody have any ideas on things I can check on how to fix this? The hot weather is killing me in this thing, like a sauna. Thanks!
 

·
Registered
Joined
·
238 Posts
have it checked to see if there is a leak in the A/C piping. if not then have it recharged. note: you may be charged 2 x's for the recharging. one to find out where the leak is & fix it , the other to recharge it.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
You sure it could be piping? I've read other places that 92's had issues with wiring getting fried. Because when I have the car on, idling, I don't even hear the compressor going on, so it makes me think that its not something wrong with coolant.
 

·
Registered
Joined
·
124 Posts
MOST of the air conditioning systems have a pressure safety switch. Whats this do? It wont let the compressor come on if the system is low on refridgerant, its that simple. Have the system professionally checked because a small pin hole or a faulty/loose hose connection could be the culprit, and unless you have the tools or the training needed to diagnose the leaks its generally best to leave it to somone who is trained and CERTIFIED.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #7
Hah no doubt. I had a friend get anti-freeze sprayed on his arm when messing around with his car and it wasn't a pretty picture either.
 
1 - 7 of 7 Posts
Top