Toyota Nation Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 · (Edited)
Hi evryone im new to this forum. Im in need of some dire help. I have a 93 tercel that was originally not passing its emissions test. I decided to clean off the excess carbon deposits in the EGR valve and cleaned the carbon in the trottle body. When doing so i had to remove the injectors to remove the throttle body. I have placed everything back to its original place and now my tercel is running rough. I thought maybe a few revs would let me place it back to normal but the car hesitates when reving past 4k. I think my injector placement or my egr might be at fault but I have no idea what is going on :confused: help would be appreciated.

thanks,
Rob
 

·
TN's ex-Local Buddhahead
1992 Toyota Paseo
Joined
·
389 Posts
Did you replace the injector o-rings?
How difficult is it to do this? If you order a set of new injectors, does it come with tools to install the o-rings? I've read that misinstalling the o-rings is a rather common occurrence... I'd like to attempt this soon, as mine are way overdue.
 

·
Registered
Joined
·
510 Posts
How difficult is it to do this? If you order a set of new injectors, does it come with tools to install the o-rings? I've read that misinstalling the o-rings is a rather common occurrence... I'd like to attempt this soon, as mine are way overdue.
Its really very easy to do, you should replace the o-rings and grommets( lube with fuel).The only problem That I can think of is if you rolled on the o-ring or nicked it.
 
1 - 4 of 4 Posts
Top