Toyota Nation Forum banner

1 - 18 of 18 Posts

·
Registered
2002 Avalon XL
Joined
·
53 Posts
Discussion Starter · #1 ·
Can anyone recommend a good quality aftermarket power antenna, motor and everything......Mine went south the other day and will not head north........

Jason
 

·
Registered
Joined
·
230 Posts
You could also do a S2000 antenna conversion. If you search you will find directions on how to do it and pictures. I did it and it looks and works great.
 

·
Registered
2002 Avalon XL
Joined
·
53 Posts
Discussion Starter · #4 ·
I was hopeing an aftermarket one would be more reliable than stock. I will check into the S2000.....

Thank you,

Jason
 

·
Where are we going today?
Camry 00/Corolla 19
Joined
·
2,614 Posts
go w/ s2000 antenna.
get that off ebay also or u can check with honda.

OEM, might break in the future
 

·
Lost to follow up!
96 Camry Coupes
Joined
·
12,154 Posts
Just replaced mine on the 3.5, got it off ebay for 11 bucks. If you hear the motor working, then you only need the antenna and the cable thing!
 

·
Toyota-Lexus Fanatic
95 Camry LE
Joined
·
805 Posts
S2000 Rocks!

No mess with frozen antennas.....do you not hate it when it is stuck frozen?

S2000 looks cool, too.
 

·
Premium Member
'96 Camry XLE
Joined
·
11,246 Posts
mandyfig said:
S2000 Rocks!

No mess with frozen antennas.....do you not hate it when it is stuck frozen?

S2000 looks cool, too.

I never did see yours completed! Any pics?
 

·
Lost to follow up!
96 Camry Coupes
Joined
·
12,154 Posts
Had to fix mine again today....just stopped midway, the cable thing became bound up in the motor, not sure why?...but I got it working again, had to take the cover of the motor over and over, couldn't seem to make it catch!......That S2000 antenna is looking better every minute!

I need more information on getting one!
 

·
1993 Camry XLE
93 CamXLE/73 Lincoln
Joined
·
1,083 Posts
Do the S2000 antenna. Plus, they aren't three feet tall like the OEM one is when it's up. Though I do like how the OEM one looks in the down position.
 

·
I know parts!
Joined
·
71 Posts
isn't it just normally the mast that goes bad?
not the motor?

I only ask because mine doesn't work and it looks like the top section is missing (cable normally attaches to it)
 

·
Premium Member
'96 Camry XLE
Joined
·
11,246 Posts
internetautomar said:
isn't it just normally the mast that goes bad?
not the motor?

I only ask because mine doesn't work and it looks like the top section is missing (cable normally attaches to it)
More times then not, it is the Antenna that goes. I did the S2000 when my motor went. :lol:
 

·
Lost to follow up!
96 Camry Coupes
Joined
·
12,154 Posts
internetautomar said:
isn't it just normally the mast that goes bad?
not the motor?

I only ask because mine doesn't work and it looks like the top section is missing (cable normally attaches to it)

My motor worked fine, the cable broke! (1st time)....Yesterday I noticed it was up again, you would hear the motor run for just a second and stop...thought the motor went bad, When I took it apart the cable had become bound inside the motor somehow:eek: So I removed it and the motor was fine, then I had to get it to feed inside again, had the wife turn the radio on and off for me, cussed alot:hammer: Took the motor apart like 5 times before i could get it to work...it would go in so far and jam again!...finally when I was ready to throw the fucker over the house:lol: ..It fed all the way and is working OK for now!....I'm pretty sure its going to stop working again!
 

·
Registered
Joined
·
3 Posts
So would this mod work for a wagon? Been dealing with a broken mast and had planned to get one from a junker, but after reading this I'm not so sure that's a good idea. Being unfamiliar radio waves, would the antenna, being so close to a taller part of the car, not get reasonable reception?
Thanks
James
 

·
Premium Member
'96 Camry XLE
Joined
·
11,246 Posts
It MAY work, but the reception would not be good at all, bcause of the reason you stated. :(
 
1 - 18 of 18 Posts
Top