Toyota Nation Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
I am hoping that some here can help me with my problem. I have a 1996 Toyota (4 cylinder) Camry that has been cutting off on me. I have tried cleaning the throttle body and idle air control valve to see if that would fix the problem. It worked for awhile then started cutting off again. I then replaced the IACV but that did not help. The hoses are fine. No cracks. The car is cutting of when I stop. It revs high, low, high then cut off. Sometimes it just revs low and then cut off. Sometimes it cranks back up right away and sometime it does not. Also, sometimes when I put it in park to revs to about 6000 rpm. Another thing, when I am driving it speeds up (jerks forward) a little by itself. Last, it does not accelerate like it should. I really want to keep the car because I cannot afford to buy another one.
 

·
Registered
Joined
·
6,149 Posts
First, your car is OBD2. That means you can go to places like Autozone (or other auto parts stores) and ask to have the codes read for free. Report back here with any codes. If no codes are present, then check for vacuum leaks. If no leaks are evident, check the coil inside the distributor. You will need a digital volt/ohmeter and the specs from any manual to do this. There are manuals available for free downloading over at the top of the Camry forum at AutomotiveForums.com. Download the generation 3 Camry manual. The coils on these cars can go out of spec and can also develope hairline cracks when they get a lot of miles on them. An aftermarket coil can be had at most auto parts store for $40-$50.

Mike
 

·
Registered
Joined
·
12 Posts
Discussion Starter #3
Mike thanks for the advice. I did the OBD2 scan and there were no errors. I will be checking for vacuum leaks tomorrow. I did change the ignition coil. The car has 207,000 miles on it. Someone told me that the reason it might be cutting of is the EGR Valve. Also, we found out that the person that changed my IACV put on two of the hose wrong. I will see how it runs in the up coming week.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #5
So far the car is not cutting off. When I had the IACV replaced the crossed the hoses, I think that was causing it to cut off. It has not cut off and it starts up better since I replace the ignition coil.

The only issue I am having is the car seems to jerk forward sometimes when I am dirving. I feel it more when the AC is on. Any ideas?


Thanks again for the help.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #8
Thank you all for your advice and sorry it took so long for my response. Here is what I have done; I have changed the IAC valve, EGR valve, ignition coil, spark plugs, spark plug cables, the rotor button, and distributor coil. After all that, I am still having issues.

The issues are;
When I am idle the car will rev a little above 1000 rpm then it will idle ok. Once in a blue it cuts off.
Sometimes after coming to a complete stop, when I step on the gas the car acts like it want to cut off. It jerks forward and acts like it want to cut off. I sometimes to does it twice but goes.

Does anyone have any ideas?
 
1 - 11 of 11 Posts
Top