Toyota Nation Forum banner

1 - 6 of 6 Posts

·
Registered
97 Previa LE AllTrac
Joined
·
4 Posts
Discussion Starter #1 (Edited)
Have a 97 SC AllTRAC, w/195K miles quit while doing approx 50mph on hwy. Very short "stutter" then died just like turning off the ignition. Check for spark from the coil to distib. on the side of hwy. Nothing. Towed home. and since then.
Checked
1. Resistance of coil, even tried a diff 1.
2. Resistance of coil wire, and connector.
3. Power to igniter.
4. tried diff igniter.
5. Resistance to Crank Posit. Sens. pulled cps and cleaned it.

Has new plug wires, plugs distrib cap

Check eng light was on approx 2 weeks, and the code was 302 (cyl 2 mis fire?)

Any suggestions???

Is it worth pulling the ECM , OPENING it and checking for any BURNT?? connections???

Also the book says to check the air gap in distrib?? would that make it quit like so??

I'm in Maryland.
Mike 410 279 7328
 

·
Registered
Joined
·
108 Posts
When my 95 s/c died, the rotor had come loose from inside the distributor cap. If that is the problem, use loctite on the threads. I see that you get no spark coming from the coil to distributor so it should not be the rotor anyway. Maybe the wires?
 

·
Registered
97 Previa LE AllTrac
Joined
·
4 Posts
Discussion Starter #3
Rotor is fine , checked all that
Tried diff igniter, coil, checked the CPS
Latest interesting development is that the check engine lite HAD been on b4 the van died.
I bought a code reader and it fails to link w\ ECM?? And the c e lite doesn't come on while cranking!!!
My buddy says this points to the ECM?!?!?!?

Come on Previa Phorum !!!! Im trying to drive this
Avocado cross country.
Any input??
 

·
Registered
97 Previa LE AllTrac
Joined
·
4 Posts
Discussion Starter #4
Update?

Well I pulled the ECM and sent it out to S.I.A. Electronics in Illinois..........
$90 charge for evaluation/diagnostics...
$270 for a reman/rebuild w/a lifetime warranty

Actually hope it is a prob w/the ECM.......last resort on the NO SPARK Check List....
'
 

·
Registered
Joined
·
44 Posts

·
Registered
97 Previa LE AllTrac
Joined
·
4 Posts
Discussion Starter #6
WTF?!?!?!?!?!?!?

S.I.A. Auto Electronics in Illinois, couldn't get their diagnostic equipment to Communicate w/my ECU........
They say the "Processor" is fried......? After advertizing $270 to rebuild an ECU , they wanted to charge $500 for a replacement??
I just ordered a used/working ECU off of Ebay for $80 ,, we shall see?


ANY Comments???
 
1 - 6 of 6 Posts
Top