Toyota Nation Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
All,

thanks in advance for the help.

I have an 03 Camry 4cyl. The A/C Light just started flashing and the clutch never engages. I have checked the fuses and relays in the Dash Fuse box and the Under hood Fuse box. All seem to be good and working.

I have found this TSB EL011-05..... Don’t know what is is for sure, but t may help. Can anyone run an alldata or tell me what it is.


Thanks
Matt
 

·
Registered
Joined
·
567 Posts
If you are low on freon your A/C/ clutch won't engage because of the low pressure switch. You should be able to check this by jumpering the switch. However you may have a leak that needs to be fixed by a GOOD a/c shop!

Gary
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
There is not a leak in the A/C system. the clutch would engage for a second if there was, unless it was completly empty.
 

·
Banned
Camry / 2WD Pickup
Joined
·
601 Posts
Sorry, but the only experience I have w/ this type of problem was w/ my Gen 1 Camry.

The A/C light was blinking when I tried to run the A/C. I had to install a new RPM sensor into the compressor. It was a PIA, since the system needed to be opened.
 

·
Registered
Joined
·
567 Posts
keltymd said:
There is not a leak in the A/C system. the clutch would engage for a second if there was, unless it was completly empty.
Exactly! Have you checked your pressures? High side and low side? Until you do you may not know if you have a leak!

Gary
 
1 - 5 of 5 Posts
Top