Toyota Nation Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I noticed today that air conditioner in my 2015 Toyota Tacoma Prerunner started working but after about 30 seconds, the air conditioner button on console started blinking and cold air stopped coming. After turning air conditioner off and restarting it the same story happened, 30 secs of work and than blinking button and warm air. Should I take it to mechanic or is it something I could fix on my own.
 

·
Premium Member
Joined
·
2,528 Posts
Blinking light means a problem. Forget if its charge (most likely based on your notes) or something else. No time to look through manual right now. Open the hood, watch the compressor, and have someone push the button, see if clutch pulls in, then kicks out after 30 seconds.
 

·
Premium Member
Joined
·
2,528 Posts
Here are some of the conditions that will stop the AC from working

Evaporator outlet air temperature is too low.
There is a marked difference between the compressor speed and the engine speed. (belt slippage)
The refrigerant pressure is abnormally high or abnormally low.
The engine speed is too low.
Rapid acceleration occurs.

On vehicle testing requires gauges on both high and low sides for compressor.

There are multiple no cool air comes out options, including
Compressor fail
Blower fail
Air mix damper servo
insufficient cooling

Each of these has multiple options to look at.
 

·
Registered
Joined
·
5 Posts
I noticed today that air conditioner in my 2015 Toyota Tacoma Prerunner started working but after about 30 seconds, the air conditioner button on console started blinking and cold air stopped coming. After turning air conditioner off and restarting it the same story happened, 30 secs of work and than blinking button and warm air. Should I take it to mechanic or is it something I could fix on my own.
Quick check
If you have not do any repair done to your truck
check what diagnostic trouble code you have--if the dtc says something about compressor lock try this below
check if your ac system has the right amount of refrigerant
check your ac clutch compressor if it does work (engage or disengage) if found to be working properly your issue maybe a failing ac amplifier module
 
1 - 4 of 4 Posts
About this Discussion
3 Replies
3 Participants
PoorAss
Toyota Nation Forum
ToyotaNation Forum is a community dedicated to all Toyota models. Come discuss the Camry, Tacoma, Highlander, 4Runner, Rav4 and more!
Full Forum Listing
Top