Toyota Nation Forum banner

1 - 7 of 7 Posts

·
TN's Resident Car Whore!
'95 DSM Eclipse RS
Joined
·
5,978 Posts
Discussion Starter #1 (Edited)
I wanted to install the rest of my sound setup which includes a Profile California series 400sx amp and a 12" audiopipe bass tube and a 10" sony xplod sub. Right now i currently only have in my Balupunkt Sacramento H/U. The thing is my battery light comes on most of the time, but sometimes it's off for a while. I also have fogs and a neon tube installed in my car and these are on a regular basis and i have never had any trouble with starting or anything like that and it has been this way for couple months now and still it doesn't have any starting problems or anything related other than the battery light comes on. When i went to make them test it, everything was working well it was charging good and everything. Could it be my that my battery is too small? cuz i do have a pretty small battery. Also do you all think i would have problems if i install the rest of my sound setup and disconnect the fogs and neon so that soo much power isn't being pulled? So basically i wanna know if it would be cool to go ahead and still install these things and just cut back on other acc. that use up power and i won't have any probs. plus i don't plan on playing the subs real hard until i can really check it out.
 

·
Registered
Joined
·
219 Posts
dna59 said:
I wanted to install the rest of my sound setup which includes a Profile California series 400sx amp and a 12" audiopipe bass tube and a 10" sony xplod sub. Right now i currently only have in my Balupunkt Sacramento H/U. The thing is my battery light comes on most of the time, but sometimes it's off for a while. I also have fogs and a neon tube installed in my car and these are on a regular basis and i have never had any trouble with starting or anything like that and it has been this way for couple months now and still it doesn't have any starting problems or anything related other than the battery light comes on. When i went to make them test it, everything was working well it was charging good and everything. Could it be my that my battery is too small? cuz i do have a pretty small battery. Also do you all think i would have problems if i install the rest of my sound setup and disconnect the fogs and neon so that soo much power isn't being pulled? So basically i wanna know if it would be cool to go ahead and still install these things and just cut back on other acc. that use up power and i won't have any probs. plus i don't plan on playing the subs real hard until i can really check it out.
I don't really understand what you're trying to say. If you could rephrase I might be able to help. As of now it sounds like you have a head unit, sub and amp installed. You run neon lights and fog lights and your battery light is coming on? What is the rest of our sound setup? If you're having problems now, adding more load is only going to cause more problems. Your lights aren't taking up that much power. What kind of amp are you looking to install?
 

·
TN's Resident Car Whore!
'95 DSM Eclipse RS
Joined
·
5,978 Posts
Discussion Starter #3
Well I actually already installed my amp its a Profile California Series 400sx amp. However I'm gonna go and have the alternator taken of and checked out to see if it's actually the alternator. The thing is my battery lights comes on and goes of. I know it's not the battery cuz i tried one of my buddies battery and the light still comes on and the alternator still charges up and everything and I have never had any problems with starting or anything related to a bad alt.
 

·
Registered
Highlander
Joined
·
1,535 Posts
This is how to test your alternator easily. Get a voltmeter, digital preferred, and test the voltage across the battery when the car is 1) off and 2) on. If the voltage reads about 12V when off and around 14V when on, then the alternator is fine. If it stays around 12V when on, then you may need to get a new alternator.

For your current and planned setup, it doesn't seem like you would need a new alternator, unless the car is older.
 

·
TN's Resident Car Whore!
'95 DSM Eclipse RS
Joined
·
5,978 Posts
Discussion Starter #5
Thanks alot for your help. I'm going to have them check out my alternator today. This is the last thing that needs to be probably repaired or replaced since I bought my car. So i wanna hurry get it out the way.
 

·
TN's Resident Car Whore!
'95 DSM Eclipse RS
Joined
·
5,978 Posts
Discussion Starter #7
I did the big 3 and it took my battery light right off.
 
1 - 7 of 7 Posts
Top