Toyota Nation Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
66 Posts
Discussion Starter · #1 ·
I have a pull thats strange. At 117k miles replaced many parts, only thing left tie rods they seem fine, wheel bearing,cv joint. There is a click sometimes when driving from a stop going straight. Sometimes the suspension freaks out and boinggggggssssss going over certain freeway roads and always pulls right when doing it. So far ive replaced ball joints,rotors,pads,strut,strut mounts, the tie rod doesnt seem to have any movement the inner tie rod seems ok.
 

·
Banned
Joined
·
212 Posts
sounds to me that its the road more then the car.
does this happen on other roads or just this one freeway?

how are the tires and what about the alignment?
 

·
Registered
Joined
·
66 Posts
Discussion Starter · #3 · (Edited)
Your kidding right?

I have a forsale sign in the car!!! Someones getting a car with lots of new parts. Its a defect in the car trust me i know that for sure. Kinda of pull that makes your hair stand up on neck! Its not as bad with new control arms and new bushings. I gave the dealer a chance to fix Brett Brown Toyota they did a lousy job, spent $400 and nothing but frustration they really are poor. Everything the dealer touched either messed up my car like there brake job or left bolts loose by accident or intentional? Im thinking the cv joint could be causing this wierdness thats hard to diagnose like a multitude of problems play here play there all adding up. Toyota has the worst suspensions going, there's nothing holding the strut housing from moving. Design issue that could have been built right and to last. I may check out the subframe bolts for tightness maybe someone loosened them up or factory screwed this up. Car drives like new around town but out on freeway over certain streches the drivers side of the car freaks out. I gave the tie rod a few turns to make it shorter and things improved but even with the alignment left on that side over the bumps it still goes right? I hope this is something simple like play in inner tie rod or outer but i havent pulled the tigger and purchased those parts. I even had PEPBOYS put it on the rack and asked them to check this out. Nope nothing, i said serious there's something wrong. Back up it went and i got under with the tech, we found control arm moved back and forth inch or so! The design of bushing set for comfort really an oversight for TOYOTA! So throwing parts at this car seems make most sense right now heck there's only few parts left wheel bearing,inner and outer tie rods,cvjoint. I can get bearing $30 online,Autozone axle cv $59, $40 for both tie rods ebay macparts $130 and my time, still cheaper than one hour of mecanic time. Though id like to save some money and my time lol no more getting under that car.
 

·
I Like Traffic Lights !!!
78 Bronco
Joined
·
520 Posts
Before you sell the car you might want to try a new set of tires, when I did my first tire change over I had put a set of tires on my Corolla that made my car act the way yours is and because it was under warrenty I let the dealer deal with it and it wasn't untill we pulled a set of tires off one of the cars on the lot at the dealer and put them on my car just to try it out that my car changed. It was night and day the difference in ride and the way it would handle.

I can't remember the name of the tires I had on my Corolla that made it do that but it's worth a try or even do like I did and just borrow a set to see if there is a difference in your car.
 

·
Registered
Joined
·
135 Posts
..

it sounds like its the tyres could be bad happened to me i put four new tyres on my car not long ago and it start pulling all over the place they were crap tyres try this last thing maybe put a set of good tyres on and see make sure there balanced right and get the alignment done last resort your like me always throwing money into the car some people just think its in are head...we just know when its not running right
 

·
Registered
Joined
·
66 Posts
Discussion Starter · #6 ·
LOL i wish it was tires

Here is some information on why this problem maybe happening. Discount Tire installed the wrong size tire. Thats three correct tires and one 205 size tire. Yes they installed it on drivers side front! If you think about it like an engineer, all the load first gets placed in this area because larger diam tire. If it knocked out my alignment and i drove this way 15k miles. Discount tire has been great for me personaly so i didnt put up a fuss. I would like to get my car working like new again though. Throwing parts at it seems to make most sense at this point. Guess who foundout the wrong tire was on there WALMART!!! I know cant belive it myself. Could this have done the transaxle damage? The right tire would have to slip constant and heat up fluid right? I wish they placed this on back tire grrrrrr. Im about done trying to fix myself its giving me grey hairs. Car drives sweet in city its out on freeway it shows its self. Drives like a new car because i replaced dang near everthing on the car. Maybe a bearing got messed up but not showing the howling yet like a nick in couple surfaces. Maybe a subframe is loose, plus worn out stabalizer bar plus alignment issue and play in inner tie rod a little adds up to my problem lol?:Bruce:
 

·
I Like Traffic Lights !!!
78 Bronco
Joined
·
520 Posts
Did you replace the tire? How do you know all that stuff is wrong? I'd put the proper tire on it and maybe change the tranny fluid, I'm sure the car will be fine and your working yourself up over nothing.
 
1 - 9 of 9 Posts
Top