Toyota Nation Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
So I have a 92' camry V6 XLE, I was doing some work on it and drove it up onto some wood blocks and applied the parking brake, I have a foot parking on left side of drivers side. After a few days I back up off the wood blocks forgetting the parking brake was on, After I drive off I quickly unset it.

Anyways now the back left wheel is doing this horrible squealing sound when I am in drive (I don't need to push the brakes, and it never happened before I took it on the wood blocks) but it'll be fine when I am in reverse. I rarely use the parking brake so I heard that the cable can seize up with rust if it isn't used often and can get stuck. Problem is I don't know what this cable looks like, or if the problem really is the parking brake.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
I don't really want to change the cable or anything, I heard that tugging on it to get the slack or something out would fix the problem, but again don't know what it looks like. Does this really sound like a parking brake issue or something else, though I tried putting it in neutral on a hill and it wouldn't move, but if I am driving up a hill and put it in neutral it will move backwards. Sorry but 2 links and nothing else isn't very helpful.
 

·
Banned
Car
Joined
·
417 Posts
I tried putting it in neutral on a hill and it wouldn't move, but if I am driving up a hill and put it in neutral it will move backwards. Sorry but 2 links and nothing else isn't very helpful.
your car move straight?or it turns to left (or right)?
 
1 - 6 of 6 Posts
Top