Toyota Nation Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1 (Edited)
Hello all...i have a 98 avalon with 179,000 miles...i was driving on the freeway and the air conditioner went out...i checked the fuses and it was blown....i replaced the fuse and it blew again....air conditioner nor the heater nor fan will work.....any ideas?
 

·
Registered
01 Avalon XL, 03 Avalon XL
Joined
·
987 Posts
You'll need a wiring diagram for that circuit -- something is drawing too much current. Sorry, I don't yet have one (yet) and mine would be for Gen2 anyway.

Could be a short where a live wire touches metal on the car body (short to ground) or a live wire touches a bare ground wire. This is possible anywhere along a wrapped harness because wires can chafe off their insulation, usually at sharp bends in the harness or areas where thin-ish body elements impinge on the harness.

Could be a jammed blower motor because some motors draw a lot of current if they aren't rotating, or the fan motor might have an internal short.

Since the heater/AC fan isn't working, I think you can rule out the electrical clutch on the A/C compressor.

You may have to remove the dash/instrument panel to get to the wiring...

Unfortunately, because of the time required to trace down electrical problems, if you leave the labor to a shop you can anticipate a big bill.
 

·
You asked for it...
98 Avalon
Joined
·
374 Posts
i replaced the fuse and it blew again....air conditioner nor the heater nor fan will work.....any ideas?
To be clear, did you run the fan without the AC turned on, and the fuse blew again?

If yes,then I would try unplugging the fan, turn the switch on again, and see if the fuse blows.
 
1 - 3 of 3 Posts
Top