Toyota Nation Forum banner
1 - 7 of 7 Posts

·
Old fogey
Joined
·
1,429 Posts
Discussion Starter · #1 ·
So I get in my car this morning and it's driving along as usual. Then I accelerate from a stop and hear this whiny noise (I think coming from the rear). I noticed then that although my speakers were playing ok, my subs had completely cut out. I got out of my car to check what was going on to find that the amplifier no longer had its power light indicator on. So here I think "crap I blew a fuse" so I check the fuse in line with the power cable coming from the battery and it's fine. I also check the fuse that's in the amp itself and it's fine. Any ideas on what's causing my amp to not power up? Could it be blown? Everytime I accelerate now, I have this whiny noise that occurs in tandem with the motor.

EDIT: the whiny noise actually sounds as if you had a small crack in the window open and wind was blowing through.

God I hope my amp's not blown.
 

·
A Poor College Student
1994 Camry Sedan LE
Joined
·
354 Posts
I had a similar experience back when I had my Buick LeSabre. I was on my home from school and the bass suddenly disappeared.... checked the wiring and found that the power wire at the amp had exposed itself from the spade connector and shorted to the underside of my passenger seat. My POS Jensen amp couldn't handle it and it died (lesson learned: no more Jensen). I'd check ALL wiring, especially around the amp and battery, for any that's exposed.
 

·
Old fogey
Joined
·
1,429 Posts
Discussion Starter · #3 ·
Alright I managed to fix the issue. Apparently the remote turn on wire had become partially disconnected, but because it had not fallen off completely, I didn't notice it at first. You were right about the whole check wire procedure Wolf. Good thinking. Damn I'm glad that I didn't fry my amp. :D
 

·
A Poor College Student
1994 Camry Sedan LE
Joined
·
354 Posts
It's good to know that it was as simple as a loose wire.:thumbup: As for Kenwood, I'm not a big fan of their amps, but I've got exceleon components up front... :cool:
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top