Toyota Nation Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter · #1 ·
Hi guys! I have a problem with my transmission and I hope to get some help. Transmission shifts from 1 to 2 and from 2 to 3, but on the highway it doesn't shift to the last one(4th or O/D, correct?). So, does anybody know what could be the problem? Thank you.
 

·
Pochacco Owns Me
Joined
·
3,123 Posts
does it always do it ?? or does it shift to 4th after awhile ?? does it say OD off on your gear indicators ?
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #5 ·
No, reverse is fine. Just to O/D. When I drive like 45-55mph and tranny should go to the last gear, nothing happen, only RPMs go higher and higher, killing the engine. Maybe that big button "manual shift override"next to switch stick doesn't work, what do you think?
 

·
Registered
Joined
·
3,115 Posts
Do mechanical test:
Locate 6 pin solenioid connector on the tranny (located just below starter) and unplug it
attach tachometer to the engine if you don't have one (base model)
start the engine and shift to 2
slowly accelerate to 25 mph, go at constant speed, then move selector to "D"
if no shift felt / no rpm drop is noted there is a mechanical problem in the tranny.
If shift is noted then do electrical test:

If your o/d off switch indicator is coming ON with O/d off button released, you need to check the signal wire (green-orange) from tranny computer terminal 5 to the o/d switch
Get access to the tranny computer (located above the glove box)
Unplug connector from it with ignition OFF and o/d switch in “off “ position there should be continuity (0 ohms) between the Green/orange wire (terminal 5) of the connector and the ground.
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #7 ·
Ha! It was just a small frkn o/d button on the speed stick, the light showing O/D on/off didn't work. Another question: how much does the a140e cost(used)?
And my brake light next to speedometer is constantly on, you guys have any idea what it could be? First, when I was driving with no O/D gear, it was like on-off on-off, but right now it is constantly on. Its all because of the transmission or brakes? Looks like there is no leaks of brake fluid. Maybe I have to change brake pads?
 

·
Gen 2 camry Guru
91 Camry Base
Joined
·
124 Posts
Ha! It was just a small frkn o/d button on the speed stick, the light showing O/D on/off didn't work. Another question: how much does the a140e cost(used)?
And my brake light next to speedometer is constantly on, you guys have any idea what it could be? First, when I was driving with no O/D gear, it was like on-off on-off, but right now it is constantly on. Its all because of the transmission or brakes? Looks like there is no leaks of brake fluid. Maybe I have to change brake pads?
Well you need to check three things. The condition of your E-brake and in the trunk is a brake light relay/yellow box check to make sure it hasn't failed and while your in there check the condition of your brake light bulbs and make sure everything is working as it should.

There lies a possibility of the switch with the ebrake having problems you will need to remove your center console to get at it.
 

·
3s-gte in a Camry?!?
'89 Camry Alltrac
Joined
·
8,793 Posts
omg, it was just a brake fluid. not enough)))
Check your brake pad/shoe wear levels and make sure you have no leaks! That fluid has to go somewhere (it doesn't evaporate)...

-Charlie
 
1 - 10 of 10 Posts
Top