Toyota Nation Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I am having a huge problem with my 97... It will buck/run very rough/sometimes shut completely off while accelerating... it doesn't always do this, though. If it is cold outside, it almost never does it. If it is hot, it does it constantly. It is throwing no codes. When it is hot, if I take a left turn too hard, it will shut off, but not so for a right turn. Also the fuel gauge does not always show the correct amount of fuel. Maybe it's a fuel pump problem? anyone have this problem?
 

·
Registered
Joined
·
567 Posts
I remember the last time my truck would die on the freeway. It was the ditributor. It wobbled because the seals failed. That was points though so I'm not sure here. Nonetheless, I would check under your cap to see if the rotor looks good. Other thoughts beside fuel pump: fuel filter- probably not, air filter- only if it is really old or oily, injectors- probably will not cause car to die if one fails. Check these things, but honestly I have a feeling you will probably have to get a new pump.
 

·
Only GOD Knows
Toyota Corolla
Joined
·
1,969 Posts
I think your having a problem with "spark". Check you plug wires first. They can break easily inside the boots and appear to be ok from the outside. That would give you the hesitation while driving or "bucking". Also if it's more than one, of course your engine will die. If thats not it, check the rotor and cap.
 
1 - 3 of 3 Posts
Top