Toyota Nation Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
:confused: I have a 2001 Toyota Camry (4cyl) that I have only had for one year. I have lately been noticing a problem that over this past week has gotten much worse. When I press the gas (mostly if the car is stopped at a light or something or just been started), the RPM's go up but the car hesitates before going. This is very dangerous when attempting to pull into busy traffic and scares me half to death. Then the other day I noticed while at a stop sign on top of a hill, that when I release the break to press the gas the car starts to roll rapidly backwards! The car is an automatic. I am a female college student that always gets screwed by car dealers, etc. when taking my car in to get it worked on... can someone give me some ideas as to what might be wrong so that I can tell if they are trying to fix things that have nothing to do with the problem? Thanks!
 

·
96 3MZ M/T
Camry
Joined
·
2,879 Posts
your transmission is dying! i'm guessing you bought the car used and the people before didnt take too good care of the tranny. you can try and see if changing the tranny fluid fixes anything or get a tranny flush. personly i found that to make things worst at times better at others.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #3 ·
I did buy the car used but had it checked out by a mechanic first and they said the car was in great condition. Just found out the trans. was extremely low in fluid so I filled it back up... seems to be driving normal now... do you think I should still go and get it looked at or get the fuel injection system flushed or anything?
 

·
96 3MZ M/T
Camry
Joined
·
2,879 Posts
well the problem was in your transmission so there might be a leak. so keep checking to see if there is enough fluid every so often. everything else should be fine but maybe the transmission flush might be good to help take out anything that might of happend when it was low.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #5 ·
Thanks for all of your help... I will keep checking it to see if there is a leak or something... just didn't want to get taken advantage of by a mechanic or someone! Thanks!
 

·
I'm a Mac
DD - 94 Mitsu 3000GT
Joined
·
4,062 Posts
yeah i'd say check the bottom of your radiator where the tranny fluid goes through it and check that it isnt leaking anything. thats definitely not a dying tranny. its just low on fluid, so it doesnt function properly. theres no way you can destroy a tranny from an 01 and its now 2004. unless you jam it into reverse while moving or something...

-p.s. why is your name pleasehelp? you arent gonna be here for more than this question? sheesh.
 

·
Know God. Work Hard.
4Runner
Joined
·
2,194 Posts
Adding to what Zoni said:

The color of the fluid that your looking for should be red/dark red color. If you find anything else, then your leaking something else and thats also a problem (But a different problem).
 

·
Diablo
05 Altima SER+93 Cam
Joined
·
353 Posts
How many miles do you have on your car ? Is it still under some type of warranty ?
 

·
Banned
Joined
·
4,345 Posts
LoL Don't mind zoni, we have a lot of guys that try to pimp the ladies into staying on the board. ;)

Just park the car for a day and see if any fluid (water doesn't count!) is under the car when you back out. If you were driving with it just low on fluid, I would go get a flush when you can get the money.
 
1 - 10 of 10 Posts
Top