Toyota Nation Forum banner
1 - 5 of 5 Posts

·
2005 Avalon Ltd
2005 Avalon Ltd
Joined
·
213 Posts
Discussion Starter · #1 ·
The center brake light on the package shelf is not working. I checked the 15A fuse in the engine compartment fuse block and it is good.

Taking out the package shelf to access the light unit appears to be a real PITA.

Has anyone had a problem and what was the result?

Thank you, Peter
 

·
Avalon Enthusiast
05Avalon, 03Mustang
Joined
·
1,305 Posts
You're right. The entire rear seat and lots of trim pieces must be removed to access the center stop light.
I assume the left and right stop lights are working OK.
Since the center light is wired in parallel with the laft and right brake lights, the only possibilities would seem to be:
- Center stop light failed internally (it's just some LEDs and a limiting resistor).
- The connector became dislodged (perhaps never completely seated at the factory)
- Broken wire.

Have you tried tapping on the housing , while a helper applies the brake pedal, to check for an intermittent connection?
Has any work been done that might have involved removal of the rear "shelf" panel?
Has any unusual item been stuffed into the trunk recently (the drawing in the shop manual suggests the wire to the center stop light is routed in the top passenger side area) ?
 

·
2005 Avalon Ltd
2005 Avalon Ltd
Joined
·
213 Posts
Discussion Starter · #3 ·
I tried to respond earlier but it has been a rough day at work. I did have the windows tinted a couple of years ago and quite frankly I don't know how they could have floated the film on without removing the package shelf. I have not taken apart any of the rear trim or removed the seat, so we can rule that out. I looked at the roof of the trunk and I cannot see a harness or any connectors associated with the stop light. I spoke with my service tech at Falmouth Toyota and he said is should not be a big deal so I can stop by next Tuesday when I am in the area. I just don't have the time right now to pull the interior apart with the uncertainty as to whether that will uncover the problem area. Thank you for taking the time to think about this with me.
- Peter
 

·
2005 Avalon Ltd
2005 Avalon Ltd
Joined
·
213 Posts
Discussion Starter · #5 ·
I have the same problem and has no idea how to get it going.
I just don't know where else to look. Under the rear deck, no access, nothing really there for me to work on. Any update on how yours get fixed?
I took the car back to the dealer and even though the light was intermittent I insisted it was failing and they took the rear trim off again and I have no idea what they did but it has not failed since then. I know that is not helping you, but I decided since I have the warranty I was going to let them fool with it.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top