Toyota Nation Forum banner

1 - 4 of 4 Posts

·
Registered
1998 Camry
Joined
·
285 Posts
Discussion Starter #1
Short version - My check engine light went out, but the Torque app is still showing a "logged" fault code. I'm sure the bulb isn't burned out because the check engine light comes on when I turn on the ignition without starting the engine. Any thoughts on why the light isn't staying lit up?

Long version - I had a P0401 code for a long time (years). Finally got that code fixed by replacing the vacuum modulator. In the mean time, I picked up a P0446 code. I have replaced the gas cap. I have not gotten around to checking/replacing the airbox VSV, charcoal canister, and/or charcoal canister VSV. The other day, I was driving and noticed that my check engine light was off. I plugged in my OBDII bluetooth device and checked the codes with the Torque app. It was still showing the P0446 code as a "logged" fault, but nothing comes up under the "pending" or "historic" fault options. Any thoughts on why the check engine light isn't staying lit, even though I apparently still have a fault in the system?
 

·
Registered
Look in sig
Joined
·
8,665 Posts
Short version - My check engine light went out, but the Torque app is still showing a "logged" fault code. I'm sure the bulb isn't burned out because the check engine light comes on when I turn on the ignition without starting the engine. Any thoughts on why the light isn't staying lit up?

Long version - I had a P0401 code for a long time (years). Finally got that code fixed by replacing the vacuum modulator. In the mean time, I picked up a P0446 code. I have replaced the gas cap. I have not gotten around to checking/replacing the airbox VSV, charcoal canister, and/or charcoal canister VSV. The other day, I was driving and noticed that my check engine light was off. I plugged in my OBDII bluetooth device and checked the codes with the Torque app. It was still showing the P0446 code as a "logged" fault, but nothing comes up under the "pending" or "historic" fault options. Any thoughts on why the check engine light isn't staying lit, even though I apparently still have a fault in the system?
Sometimes I've seen the CEL goes off because I believe that the system monitoring didn't find a fault during that time, but still marks it as 'fault'? I'm not 100%, I hope other can chime in.

I've had some 'not a major' things cause the random on/off of check engine lights, but at the same time I've had CEL that made the CEL stay on all the time as well too.
 

·
Registered
1986 Toyota Pickup
Joined
·
1,671 Posts
It maybe one of those temporary codes that disappears after it takes several days of driving before the right conditions are met to complete the monitor.
 

·
Registered
1998 Camry
Joined
·
285 Posts
Discussion Starter #4
Well, the check engine light has come back on. Haven't checked codes yet, but I'm assuming it's the same P0446. Still seems odd to me that it went off for a week.
 
1 - 4 of 4 Posts
Top