Toyota Nation Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
33 Posts
Discussion Starter #1
Have a 96 4x4 with 2.7L engine. Just replaced a cracked exaust manafold with a newer design (welded steel instead of the cast iorn version) Now getting a check engine light code 0420 Catalytic Converter flow. Took to local mufler shop thinking it needed replaced since all of the exaust is going to it again and it looks brand new, no clogging at all. There are two sensors, 1 in front and one behind the converter. Do I need to replace both or start with one. They are about 100 bucks each at Advance and thats a Denso. Thanks for the input anyone.
 

·
Registered
Joined
·
33 Posts
Discussion Starter #2
I wanted to post my follow up in case the info might help someone in the future. I went ahead and replaced both of the O2 sensors before and after the Catalytic converter. The one aft was really white and burned looking but they both were probably original. I have been 400 miles and no more check engine light. This was code 0420 and again nothing wrong with the converter. I bought both sensors online for around 60.00 each and that was with the OEM plug.
 

·
Registered
Joined
·
33 Posts
Discussion Starter #4
No. Check engine light is still out. Its been close to 1,000 miles ago now so that seemed to have fixed the issue. Be sure to spary those bolts on the exuast with some PB blaster. They were really stiff and I broke the end off of one but not enought to matter. Also replace the nuts as well.
 
1 - 4 of 4 Posts
Top