Toyota Nation Forum banner

1 - 7 of 7 Posts

·
camrys blow off too!
06 subaru wrx wagon
Joined
·
554 Posts
Discussion Starter #1
ok....so i was driving to work, and all of a sudden its like really hard for me to get the car into any gear. i think wierd. on the way home i just dont use the clutch to shift after i get going. no big deal. later that day i hop in the celica to go to the store, and wtf, the clutch isnt releasing at all. well crap. i get a friend to push the clutch in for me. its got the oddest twang sound coming from the clutch. i figure the pressure plate must be fucked. no big deal.


today i took everything apart. one of the rubber bushings in the clutch hub broke and the pieces got hung in the pressure plate keeping it from releasing. then i look at the flywheel. crap!! the freakin flywheel is all cracked on the surface. so i gotta get the flywheel resurfaced. what a nightmare.

i really think it would be easier to just pulled the whole engine
 

·
Thug Engineering ST185's
Joined
·
60 Posts
your clutch must of been going for a while and it overheated due to it dragging from lack of release

mine has just been replaced due to that (have a laugh at my web site ... still in infancy at mo so bear with us )

i was greatfull for not damaging owt else tho!

but the your spares are cheaper than ours to rectify the prob!

we have 2 reasons why it fails

generaly it DEAD and nothing could of been done

the clutch is an aftermarket which is thicker so it always dragged when used, this dragging increases heat on the plate etc to which mine turned to cany floss and i lost all pedal(it dropped to the floor at the lights and never came back i had to judge gear changes for 12 miles home)

the above can be cured with an extended clutch rod

i have had them made , to which several guys in the uk use , this and the mod on the cables sorts out the stodgy gear change and drag on the clutch

PM me for more details if interested

Stu!
 

·
camrys blow off too!
06 subaru wrx wagon
Joined
·
554 Posts
Discussion Starter #3
nah, the urathane bushings in the clutch hub were worn out. they had 225000 miles on it. one of the bushings broke and wedged the pressure plate enguaged. it didnt slip at all. and the clutch disk itsself looked fine for the miliage. it was just really tired
 

·
Registered
Joined
·
40 Posts
i've also got a problem with my clutch pedal.
as of right now, I'm still able to drive it but at rest i push down on it and there's no pressure. I'm able to put it in gear but the pedal releases back just a bit and stays down. I have to pull it back towards me to get it back to normal. for the rest of the gears, the shifting is fine but the pedal still feels loose, but it at least goes back to normal rest

help me out please?
 

·
camrys blow off too!
06 subaru wrx wagon
Joined
·
554 Posts
Discussion Starter #5
check for leaks in the system, if its not that, make sure your return spring is in good repair on the pedal its self
 

·
Registered
Joined
·
2 Posts
I have a problem with my 88 gts that the thing doesn't shift smoothly at all. It's hard to get in gear at all positions, yet the clutch pedal seems just fine. It's got good pressure throughout the travel but the shift lever acts like it's sticking, especially going into first.
 

·
camrys blow off too!
06 subaru wrx wagon
Joined
·
554 Posts
Discussion Starter #7
thats what mine was doing. the pedal felt fine...i just couldnt shift to save my life of course, the car was creeping when i had the clutch in, and the car learched when i tried to start it too
 
1 - 7 of 7 Posts
Top