Toyota Nation Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
82 Posts
Discussion Starter · #1 · (Edited)
In chasing my no power problem, pulled codes and got code 51.
AC is not on, manual transmission.
Pulled efi fuse (twice) for about 5 minutes and code does not clear.
Anyone know why that happens?

Well I think it is because the throttle position switch was way out of adjustment (and has been unless something changed internally to switch).
Adjusted to specs (3 pin).


Trying to test the tps, 2.0l, the connector does not want to pull off.
Don't want to crack it.
Any tips?
Well got it off and there is a spring clip.


Thanks
 

·
Registered
Joined
·
82 Posts
Discussion Starter · #2 · (Edited)
dizzy question

Raod test showed that adjusting the throttle position switch helped, but not entirely fixed problem.

Noticed that distributor position was all the way clockwise in the accessible slot. Since you have to move it there to clear the heater hose, I wonder if the previous mechanic? moved it and did not set it back.
Have driven this car 3000mi and all highway, so do not have a baseline.
No stumbling or stalling, just no power on accelerstion.

Where is your dizzy bolt on the top left hand slot? Bottom, center, top= just asking for reference as I know they are all different.

Yes Im going to do the timing as soon as I find out if my 30 year old ACTRON timing light still works.:lol:
Any thoughts?
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top