Toyota Nation Forum banner

1 - 2 of 2 Posts

·
Just found TN and love it
Joined
·
82 Posts
Discussion Starter #1
It appears I have fixed all my fault codes except this one. My car does shift a little rougher than it used to. It uses more gas. And the O/D light acts up going off and on at intervals. I have been driving like this for about 30k miles now. At first I thought tranny was acting up so I changed transmission fluid. Old one was not too bad.
Now my question is this: Has anyone here changed the solenoid E? My trusted mechanic won't work on tranny. I do feel nervous about doing this myself but I have read all the nightmares of people going to the shop to get this repaired. I have done some research and I am thinking about tackling this. I have done my valve cover gaskets and my timing belt but I just have been learning from my book and this site. I am no mechanic. I am looking for advice and things I need to watch out for. Any help is highly appreciated!
 

·
Just found TN and love it
Joined
·
82 Posts
Discussion Starter #2
Visited junkyard

I consulted my Factory Manual and with the help of this video:
, decided it was a good idea to visit junkyard to learn how to do this job. It was quite an education! A messy little job indeed. I did find the solenoid in question but it checked out shorted. No resistance between positive terminal and ground. I guess I will have to go back and attack another valve body. By the time I get a good solenoid I should be primed to tackle the real thing. I will report back when and if I do it.
 
1 - 2 of 2 Posts
Top