Toyota Nation Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
4,519 Posts
Discussion Starter #1
I usually don't drive on the highway, but I had to pick up relatives from the airport. One the first trip to the airport everything seemed fine, then when I was heading to the airport again the Temperature Gauge was lower than normal. It freaked me out because it was so low, and I noticed the engine smells more, possibly because the engine is not at the correct operating temperature. What could the problems possibly be? I'm thinking the thermostat maybe not be operating correctly, going to take it into Auto Tech tomorrow and see what my teacher says. Any help is appreciated.
 

·
Administrator
Joined
·
14,508 Posts
Yeah, a stuck-open thermostat would be the first thing I'd look for.
 

·
Registered
Joined
·
4,519 Posts
Discussion Starter #3
Update:
I have noticed that the temperature goes down when I am driving at highway speeds (50+). This possibly means that it could be the fan switch, because it doesnt happen while driving in the city. I also sat in the car for about 10 minutes before school and it was at the correct operating temperature. Then later today I was letting the engine idle while watching the fans and they would come on and off for about 10 seconds. Possibly fan switch now:confused:
 

·
Registered
Joined
·
123 Posts
Got in my car this morning and was on the freeway before the engine was completely warmed up. Noticed the temp guage riding at the 3/8 mark until I got off the freeway. Then it went to the 1/2 mark and pretty much stayed there.

When I got back on the freeway it went back to the 3/8 mark again.

I've had a lot of Toyotas and the temp guages pretty much find their spot and park there.

Sound like a thermostat to you guys?
 
1 - 5 of 5 Posts
Top